summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-04-13 14:02:19 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-04-13 14:13:03 +0200
commit29cb21b08ddec1c4b47f49ff9391975a71fa63fa (patch)
tree1db4f766fae7ceb15ee3a27749c910b1cafbab95 /dev-python/inflection
parentdev-libs/jsoncpp: Bump to 1.9.3_pre20200412 snapshot (diff)
downloadgentoo-29cb21b08ddec1c4b47f49ff9391975a71fa63fa.tar.gz
gentoo-29cb21b08ddec1c4b47f49ff9391975a71fa63fa.tar.bz2
gentoo-29cb21b08ddec1c4b47f49ff9391975a71fa63fa.zip
dev-python/inflection: bump to 0.4.0, add Py3.8, use distutils_*
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/inflection')
-rw-r--r--dev-python/inflection/Manifest1
-rw-r--r--dev-python/inflection/inflection-0.4.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/inflection/Manifest b/dev-python/inflection/Manifest
index 5411189f8772..ef2fb7f6be46 100644
--- a/dev-python/inflection/Manifest
+++ b/dev-python/inflection/Manifest
@@ -1 +1,2 @@
DIST inflection-0.3.1.tar.gz 12943 BLAKE2B cffaba9dc22444abda6cef04bc7dbd420abcdc0edca5c13bb734edd72aab631a2b50d3c37f9bd914cc8956f8afe951734db764bcced9e0837bfe75a90c527f73 SHA512 2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad
+DIST inflection-0.4.0.tar.gz 14536 BLAKE2B 18e76db58d36cc1e3b9cf60870f4ea5759d050e7f0a5bc80206e712a51cba32fd1381b602b33bcd2b9763b899681d4d868ed930d5133d029d91161118ad68198 SHA512 1fb4321701aa0d36152044e732de679629c0b72052d1ab14d3f27356701f48a51589283d6ee821d8c0afec5ce01389a67d2f6a435075120e80b2da96e49e9159
diff --git a/dev-python/inflection/inflection-0.4.0.ebuild b/dev-python/inflection/inflection-0.4.0.ebuild
new file mode 100644
index 000000000000..95b8c51742b4
--- /dev/null
+++ b/dev-python/inflection/inflection-0.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A port of Ruby on Rails' inflector to Python"
+HOMEPAGE="https://github.com/jpvanhal/inflection"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest