summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-17 17:55:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-17 17:55:48 +0100
commitc506cbfa926ae934148e9b780242fe0673c937ac (patch)
treeeee0e421ef7347afd6649702cbbb06b08d8d863c /dev-python/intelhex
parentpackage.mask: Rescue dev-python/intelhex (diff)
downloadgentoo-c506cbfa926ae934148e9b780242fe0673c937ac.tar.gz
gentoo-c506cbfa926ae934148e9b780242fe0673c937ac.tar.bz2
gentoo-c506cbfa926ae934148e9b780242fe0673c937ac.zip
dev-python/intelhex: Enable tests, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/intelhex')
-rw-r--r--dev-python/intelhex/intelhex-2.2.1-r1.ebuild (renamed from dev-python/intelhex/intelhex-2.2.1.ebuild)12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/intelhex/intelhex-2.2.1.ebuild b/dev-python/intelhex/intelhex-2.2.1-r1.ebuild
index 2b8b2111c4e2..a2f38563881d 100644
--- a/dev-python/intelhex/intelhex-2.2.1.ebuild
+++ b/dev-python/intelhex/intelhex-2.2.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -13,3 +13,13 @@ SRC_URI="mirror://pypi/I/IntelHex/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # upstream don't run their own tests when releasing...
+ [[ ${PV} == 2.2.1 ]] || die "Revisit on bump"
+ sed -i -e 's:2.2:&.1:' scripts/*.py || die
+
+ distutils-r1_src_prepare
+}