summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-01-16 15:19:29 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-16 18:46:36 +0100
commitee0c4d78ebe8a79f97377105f8be214c7b9dd52d (patch)
treecc468a1be0867b7ae34a5c3afd447f37da174d7b /dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild
parentdev-python/python-discid: add py3.5, doc, tests, EAPI=6, fix deps (diff)
downloadgentoo-ee0c4d78ebe8a79f97377105f8be214c7b9dd52d.tar.gz
gentoo-ee0c4d78ebe8a79f97377105f8be214c7b9dd52d.tar.bz2
gentoo-ee0c4d78ebe8a79f97377105f8be214c7b9dd52d.zip
dev-python/ipaddr: add py3.5, fix dependencies
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3504
Diffstat (limited to 'dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild')
-rw-r--r--dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild b/dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild
new file mode 100644
index 000000000000..a2e542da174f
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.1.11-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="https://github.com/google/ipaddr-py https://pypi.python.org/pypi/ipaddr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( README RELEASENOTES )
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ if python_is_python3; then
+ 2to3 -n -w --no-diffs *.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}