summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ipaddr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ipaddr')
-rw-r--r--dev-python/ipaddr/Manifest2
-rw-r--r--dev-python/ipaddr/ipaddr-2.1.10-r1.ebuild35
-rw-r--r--dev-python/ipaddr/ipaddr-2.1.11.ebuild32
-rw-r--r--dev-python/ipaddr/metadata.xml17
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/ipaddr/Manifest b/dev-python/ipaddr/Manifest
new file mode 100644
index 000000000000..8ecc361a89f2
--- /dev/null
+++ b/dev-python/ipaddr/Manifest
@@ -0,0 +1,2 @@
+DIST ipaddr-2.1.10.tar.gz 29004 SHA256 d2c3bfd45147e5773108d2c8d3c65102ff234f06e2f1049a0febfa31dde4cca3 SHA512 5ad38ffe54e5322bd7d3c643c216647457fd797882549c40a9dad2cadf489aa1ce724e2272af9f8aa4a28eabf60f2ef99d6d730b78c7cb86a1f0cc901dde0eb7 WHIRLPOOL 0bc5a8116d4df2e35e342c9adc2563db963802256461eeb3a8187310d6d1a7a06e567a53953899122242488a366fb759ea091630a3e315de2a7acd749a945c1d
+DIST ipaddr-2.1.11.tar.gz 29046 SHA256 1b555b8a8800134fdafe32b7d0cb52f5bdbfdd093707c3dd484c5ea59f1d98b7 SHA512 a97b0f760f0d7fac549e5edf17b644c966a8858c145b8f9472ddc8bf4805c9d537f6f8755e3716d78b729b87e84149f8b73c7f98c0deee4fbf266ccb7a206bc6 WHIRLPOOL ba34b892828098e00c78df4ecfb8b79b58a6884ca5592336a96c17bbb351f65baa9c0287acc65ed166c60ce5c9317322964dd27bfe6de33a54c3bb3b08b638cb
diff --git a/dev-python/ipaddr/ipaddr-2.1.10-r1.ebuild b/dev-python/ipaddr/ipaddr-2.1.10-r1.ebuild
new file mode 100644
index 000000000000..380cfbcb122b
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.1.10-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="http://code.google.com/p/ipaddr-py/ http://pypi.python.org/pypi/ipaddr"
+SRC_URI="http://ipaddr-py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( README RELEASENOTES )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3* ]]; then
+ 2to3 -n -w --no-diffs *.py || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH=build/lib \
+ "${PYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/ipaddr/ipaddr-2.1.11.ebuild b/dev-python/ipaddr/ipaddr-2.1.11.ebuild
new file mode 100644
index 000000000000..e254666bd846
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.1.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="http://code.google.com/p/ipaddr-py/ http://pypi.python.org/pypi/ipaddr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DOCS=( README RELEASENOTES )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare() {
+ if python_is_python3; then
+ 2to3 -n -w --no-diffs *.py || die
+ fi
+}
+
+python_test() {
+ PYTHONPATH=build/lib \
+ "${PYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/ipaddr/metadata.xml b/dev-python/ipaddr/metadata.xml
new file mode 100644
index 000000000000..b039c82da95c
--- /dev/null
+++ b/dev-python/ipaddr/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <herd>python</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ipaddr-py</remote-id>
+ <remote-id type="pypi">ipaddr</remote-id>
+ </upstream>
+</pkgmetadata>