summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 15:59:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 15:59:25 +0100
commited4a85925569a32886cd88bfedaae6b249a34e29 (patch)
tree014077a5153d541487786f122510635927b959a9 /dev-python/ipy/ipy-1.01-r1.ebuild
parentdev-python/ipaddr: Switch to PEP 517 build (diff)
downloadgentoo-ed4a85925569a32886cd88bfedaae6b249a34e29.tar.gz
gentoo-ed4a85925569a32886cd88bfedaae6b249a34e29.tar.bz2
gentoo-ed4a85925569a32886cd88bfedaae6b249a34e29.zip
dev-python/ipy: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipy/ipy-1.01-r1.ebuild')
-rw-r--r--dev-python/ipy/ipy-1.01-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ipy/ipy-1.01-r1.ebuild b/dev-python/ipy/ipy-1.01-r1.ebuild
new file mode 100644
index 000000000000..3557a2fbcd28
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}