summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-21 00:54:15 +0000
committerSam James <sam@gentoo.org>2021-01-21 01:05:01 +0000
commit454d2bcc6694a517d006919a4da89294e5501e64 (patch)
treed1eac95ab8ed7670dcf0a92bd65659f555ce7e30 /dev-python/ipy
parentdev-python/smartypants: new (revived) ebuild, dep for rst2pdf (diff)
downloadgentoo-454d2bcc6694a517d006919a4da89294e5501e64.tar.gz
gentoo-454d2bcc6694a517d006919a4da89294e5501e64.tar.bz2
gentoo-454d2bcc6694a517d006919a4da89294e5501e64.zip
dev-python/ipy: bump to 1.01
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest1
-rw-r--r--dev-python/ipy/ipy-1.01.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index d6c42806e7cd..567fb54e50bd 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1 +1,2 @@
DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
+DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
diff --git a/dev-python/ipy/ipy-1.01.ebuild b/dev-python/ipy/ipy-1.01.ebuild
new file mode 100644
index 000000000000..a8260ce8a9d2
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/autocracy/python-ipy/wiki https://pypi.org/project/IPy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+python_test() {
+ # 1 test fail under pypy, persistent from 0.82a, not a regression.
+ cp -r test_doc.py README.rst test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}