summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-01 14:45:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-01 16:44:45 +0200
commit06ad8727b9a3514e3f03c659517834d9d1aa87c2 (patch)
treeab1d94fcbeb725cd08b0b2449cf44046a25f2fce /dev-python/ipyparallel
parentdev-python/ipykernel: Port to py3.10 (diff)
downloadgentoo-06ad8727b9a3514e3f03c659517834d9d1aa87c2.tar.gz
gentoo-06ad8727b9a3514e3f03c659517834d9d1aa87c2.tar.bz2
gentoo-06ad8727b9a3514e3f03c659517834d9d1aa87c2.zip
dev-python/ipyparallel: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
index 0bef8279f496..127af46a1d9c 100644
--- a/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-6.3.0-r1.ebuild
@@ -3,10 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
inherit distutils-r1 optfeature
DESCRIPTION="Interactive Parallel Computing with IPython"
@@ -16,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
# About tests and tornado
# Upstreams claims to work fine with tornado 5, and it's indeed possible to
@@ -40,7 +36,6 @@ BDEPEND="${RDEPEND}
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
"
@@ -60,6 +55,11 @@ python_test() {
ipyparallel/tests/test_view.py::TestView::test_unicode_execute
ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
)
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ ipyparallel/tests/test_client.py::TestClient::test_warning_on_hostname_match
+ )
epytest ${deselect[@]/#/--deselect }
}