summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:52:29 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 14:56:19 +0200
commit18ee4b7bb4f66c8979528f952c045e75fb480754 (patch)
treee872ad49eff16075283fcc12b79d05015f743741 /dev-python/ipyparallel
parentdev-python/pytest-tornado: import from ::guru (diff)
downloadgentoo-18ee4b7bb4f66c8979528f952c045e75fb480754.tar.gz
gentoo-18ee4b7bb4f66c8979528f952c045e75fb480754.tar.bz2
gentoo-18ee4b7bb4f66c8979528f952c045e75fb480754.zip
dev-python/ipyparallel: add version 7.1.0
Bug: https://bugs.gentoo.org/688258 Closes: https://bugs.gentoo.org/820152 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-7.1.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index bdce308ec709..d356d0d95a7a 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1 +1,2 @@
DIST ipyparallel-6.3.0.tar.gz 2380153 BLAKE2B b8312102e1d2b5fc963491ebe8530e2fd73e9f941f7912fbc72a8db51e7255f5cac95a853d15a57e384926ab1aff27f2a3ad13cc45130a8b612be5dc623538ab SHA512 fe621854b9cc3e5f88aeca2b06b63bb689dd2feee0da451a0a90800d8832f4b44b23bb9a15033029cc33179276f31e982a10fc7540e6d13b04f15d96c348a295
+DIST ipyparallel-7.1.0.tar.gz 4029033 BLAKE2B badf4bdad0dca0898e62abee3e5a48b06460160bd1f2ae096bc05beb00dbd6dc2b52681aa699d69a76f5a51e4cd3f0bb107fa6b1d20109e76bc78da8f08b69f9 SHA512 9a629bd92176dbace1724efe0a5a698b2d684128567513f8809fd25e4901227d1c7fc7b02427fd3c14b3743b47956ff8387098a1cc8759d8987aa5e3d8ca60d5
diff --git a/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
new file mode 100644
index 000000000000..7877e2a3c7b0
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-4[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.1[${PYTHON_USEDEP}]
+ "
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/ipython[test]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ ipyparallel/tests/test_view.py::TestView::test_temp_flags
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_arg
+ ipyparallel/tests/test_view.py::TestView::test_unicode_apply_result
+ ipyparallel/tests/test_view.py::TestView::test_unicode_execute
+ ipyparallel/tests/test_view.py::TestView::test_sync_imports_quiet
+ )
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # failing due to irrelevant warnings
+ ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
+ ipyparallel/tests/test_client.py::TestClient::test_warning_on_hostname_match
+ )
+ epytest ${deselect[@]/#/--deselect }
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}