summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-14 08:35:42 +0000
committerSam James <sam@gentoo.org>2021-11-14 08:35:42 +0000
commit6d3fe771b9ff45f5c3f1fef2aff83992c5326b10 (patch)
treeea21f258c7625ec52164b29290d4c2a4e4babe97 /dev-python/ipyparallel
parentdev-python/trio: skip test that times out on ia64 (diff)
downloadgentoo-6d3fe771b9ff45f5c3f1fef2aff83992c5326b10.tar.gz
gentoo-6d3fe771b9ff45f5c3f1fef2aff83992c5326b10.tar.bz2
gentoo-6d3fe771b9ff45f5c3f1fef2aff83992c5326b10.zip
dev-python/ipyparallel: crank up test timeouts
Closes: https://bugs.gentoo.org/823458 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/files/ipyparallel-7.1.0-test-timeouts.patch48
-rw-r--r--dev-python/ipyparallel/ipyparallel-7.1.0.ebuild4
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/files/ipyparallel-7.1.0-test-timeouts.patch b/dev-python/ipyparallel/files/ipyparallel-7.1.0-test-timeouts.patch
new file mode 100644
index 000000000000..2b0614e95d7d
--- /dev/null
+++ b/dev-python/ipyparallel/files/ipyparallel-7.1.0-test-timeouts.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/823458
+
+From: Sam James <sam@gentoo.org>
+Date: Sun, 14 Nov 2021 08:34:15 +0000
+Subject: [PATCH] Crank up test timeouts
+
+--- a/ipyparallel/tests/__init__.py
++++ b/ipyparallel/tests/__init__.py
+@@ -74,7 +74,7 @@ def setup():
+ while not os.path.exists(engine_json) or not os.path.exists(client_json):
+ if cp.poll() is not None:
+ raise RuntimeError("The test controller exited with status %s" % cp.poll())
+- elif time.time() - tic > 15:
++ elif time.time() - tic > 60:
+ raise RuntimeError("Timeout waiting for the test controller to start.")
+ time.sleep(0.1)
+ add_engines(1)
+@@ -107,7 +107,7 @@ def add_engines(n=1, profile='iptest', total=False):
+ while len(rc) < base + n:
+ if any([ep.poll() is not None for ep in eps]):
+ raise RuntimeError("A test engine failed to start.")
+- elif time.time() - tic > 15:
++ elif time.time() - tic > 60:
+ raise RuntimeError("Timeout waiting for engines to connect.")
+ time.sleep(0.1)
+ rc.close()
+--- a/ipyparallel/tests/test_lbview.py
++++ b/ipyparallel/tests/test_lbview.py
+@@ -21,7 +21,7 @@ class TestLoadBalancedView(ClusterTestCase):
+ self.assertRaisesRemote(error.EngineError, ar.get, 10)
+ eid = ar.engine_id
+ tic = time.time()
+- while eid in self.client.ids and time.time() - tic < 5:
++ while eid in self.client.ids and time.time() - tic < 30:
+ time.sleep(0.01)
+ assert eid not in self.client.ids
+
+--- a/ipyparallel/tests/test_view.py
++++ b/ipyparallel/tests/test_view.py
+@@ -47,7 +47,7 @@ class TestView(ClusterTestCase):
+ ar = view.apply_async(conditional_crash, ipp.Reference("should_crash"))
+ self.assertRaisesRemote(error.EngineError, ar.get, 10)
+ tic = time.perf_counter()
+- while eid in self.client.ids and time.perf_counter() - tic < 5:
++ while eid in self.client.ids and time.perf_counter() - tic < 30:
+ time.sleep(0.05)
+ assert eid not in self.client.ids
+
diff --git a/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
index 5c708589464c..a2f3bb4d73d9 100644
--- a/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-7.1.0.ebuild
@@ -42,6 +42,10 @@ BDEPEND="${RDEPEND}
# distutils_enable_sphinx docs/source
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
+)
+
python_test() {
local deselect=(
# we don't run a mongo instance for tests