summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-03-14 12:19:36 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-16 20:11:10 +0100
commite3f3ea40fd013d4f22f1ec0a6cfd8c6d3a3646e2 (patch)
treebc44002233be35c9ac29722e6497023143b57d11 /dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
parentdev-python/nbsphinx: Version bump to 0.2.13 (diff)
downloadgentoo-e3f3ea40fd013d4f22f1ec0a6cfd8c6d3a3646e2.tar.gz
gentoo-e3f3ea40fd013d4f22f1ec0a6cfd8c6d3a3646e2.tar.bz2
gentoo-e3f3ea40fd013d4f22f1ec0a6cfd8c6d3a3646e2.zip
dev-python/ipython_genutils: Version bump to 0.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4201
Diffstat (limited to 'dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
new file mode 100644
index 000000000000..b8767f4bff24
--- /dev/null
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vestigial utilities from IPython"
+HOMEPAGE="https://github.com/ipython/ipython_genutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
+}