summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-14 01:25:01 +0000
committerSam James <sam@gentoo.org>2021-03-14 01:25:01 +0000
commit4d6b994866931b3c65a262689e508f2b3b2b4383 (patch)
treee3df32728f3883a183f40a4290301fcf246fcff4 /dev-python/ipython_genutils
parentdev-ruby/ruby-gnome2: Stabilize 3.4.3 amd64, #774954 (diff)
downloadgentoo-4d6b994866931b3c65a262689e508f2b3b2b4383.tar.gz
gentoo-4d6b994866931b3c65a262689e508f2b3b2b4383.tar.bz2
gentoo-4d6b994866931b3c65a262689e508f2b3b2b4383.zip
dev-python/ipython_genutils: add missing nose runtime dep
Provides decorators which need nose. From dev-python/notebook: /usr/lib/python3.7/site-packages/_pytest/assertion/rewrite.py:170: in exec_module exec(co, module.__dict__) notebook/nbconvert/tests/test_nbconvert_handlers.py:50: in <module> class APITest(NotebookTestBase): notebook/nbconvert/tests/test_nbconvert_handlers.py:83: in APITest @onlyif_cmds_exist('pandoc') /usr/lib/python3.7/site-packages/ipython_genutils/testing/decorators.py:165: in skip_decorator import nose E ModuleNotFoundError: No module named 'nose' Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/ipython_genutils')
-rw-r--r--dev-python/ipython_genutils/ipython_genutils-0.2.0-r2.ebuild (renamed from dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild)5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r2.ebuild
index 3cd68c1222b1..f65b6cb184d5 100644
--- a/dev-python/ipython_genutils/ipython_genutils-0.2.0-r1.ebuild
+++ b/dev-python/ipython_genutils/ipython_genutils-0.2.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,4 +15,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 x86"
+# Needed because package provides decorators which use nose
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
distutils_enable_tests nose