summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-07-25 08:13:22 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-25 20:38:22 +0200
commitf22001cd762d7c742e217c732cb4a870b170bfe9 (patch)
treeeaad4e85e1d63402be97bf2f29f737b136f2065b /dev-python/ipywidgets/ipywidgets-5.2.2.ebuild
parentdev-python/widgetsnbextension: Version bump to 1.2.6 (diff)
downloadgentoo-f22001cd762d7c742e217c732cb4a870b170bfe9.tar.gz
gentoo-f22001cd762d7c742e217c732cb4a870b170bfe9.tar.bz2
gentoo-f22001cd762d7c742e217c732cb4a870b170bfe9.zip
dev-python/ipywidgets: Version bump to 5.2.2
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1961 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets/ipywidgets-5.2.2.ebuild')
-rw-r--r--dev-python/ipywidgets/ipywidgets-5.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-5.2.2.ebuild b/dev-python/ipywidgets/ipywidgets-5.2.2.ebuild
new file mode 100644
index 000000000000..aa7eb2cebaaf
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-5.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/traitlets-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-4.2.2[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-1.2.3[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+}