summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 20:29:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 20:31:19 +0200
commit98c12308878094595893863b6a4b75ba717c5780 (patch)
tree92ec90fce1b0a0acb1a1e70f0ce8e059c37add49 /dev-python/ipywidgets
parentdev-python/widgetsnbextension: Bump to 3.5.1 (diff)
downloadgentoo-98c12308878094595893863b6a4b75ba717c5780.tar.gz
gentoo-98c12308878094595893863b6a4b75ba717c5780.tar.bz2
gentoo-98c12308878094595893863b6a4b75ba717c5780.zip
dev-python/ipywidgets: Bump to 7.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.5.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index b47c09bf7a34..91ee2f70cd66 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,2 +1,3 @@
DIST ipywidgets-7.0.0.tar.gz 1006851 BLAKE2B 2ee86d0459b6c88b351994dcb4385d31378235a0be157387d90a476e49958bde25df941aa92068266df377c75dac13925d15ba2f8da0987d70adca3e726fa1a7 SHA512 39219478c12f26a2bab0e975b6fb53a7f9ee92b10fa05bd885b21c7c981a4402ad65f497223a4a2c30a7d6d18bb56bec715a20659926075f2e3730e72022ade6
DIST ipywidgets-7.4.2.tar.gz 4114472 BLAKE2B 45f946da974c1f7c5422248bd5f2eacb92a6791f089d13fb17e025b94058d97210561a6291a6c5b8c7e8e484e7128f5315db2af6cf212762f36e6d884929686f SHA512 ae5ef0615a9771cd83ca17a2a364bd5d6ee0d934d82adf2c70fde84b7c9b000d7bb32595977a607b5439423e0553c9bb8293617b43d0cf322f6bcf4b3b912eec
+DIST ipywidgets-7.5.1.tar.gz 5656334 BLAKE2B 8bd98f523b619bea02e01ae5faffb08040dc5011905dd69510728b02736e66444b3c3cdf1e7272884c1df97f610aff790063f783e1d0939786669ef39cd1fc94 SHA512 856b3e4dad331766eff6e5f1fd31984a4b6ede5c678ffd51a4896f6448dac53ba181ccec2821f10e07e0f1095318427affe19f1420d0337bc3d37ef1e0a9ea0d
diff --git a/dev-python/ipywidgets/ipywidgets-7.5.1.ebuild b/dev-python/ipywidgets/ipywidgets-7.5.1.ebuild
new file mode 100644
index 000000000000..1570b7356474
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest