summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-01 06:41:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-01 06:55:14 +0200
commita3b972a524a745aaae854001542796576a7e8aeb (patch)
tree03544b35d3d8d5460376da97990f13b3bc22962a /dev-python/ipywidgets
parentdev-python/mechanize: Bump to 0.4.6 (diff)
downloadgentoo-a3b972a524a745aaae854001542796576a7e8aeb.tar.gz
gentoo-a3b972a524a745aaae854001542796576a7e8aeb.tar.bz2
gentoo-a3b972a524a745aaae854001542796576a7e8aeb.zip
dev-python/ipywidgets: Bump to 7.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 0ff8d02c3b1e..0b5935b00720 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,3 +1,4 @@
DIST ipywidgets-7.5.1.tar.gz 5656334 BLAKE2B 8bd98f523b619bea02e01ae5faffb08040dc5011905dd69510728b02736e66444b3c3cdf1e7272884c1df97f610aff790063f783e1d0939786669ef39cd1fc94 SHA512 856b3e4dad331766eff6e5f1fd31984a4b6ede5c678ffd51a4896f6448dac53ba181ccec2821f10e07e0f1095318427affe19f1420d0337bc3d37ef1e0a9ea0d
DIST ipywidgets-7.6.2.tar.gz 4066260 BLAKE2B b0d75d83108336bac204c24d2a67e88a200939cd8308d99bdb3842916387266f24607726ce0b8781b4a8b6330b9e26bf1eeeeebcaf7588b74980d5bc6603e1b8 SHA512 a8c25ee82e0b0752f850a314fd9a05bbcdd098c9fbe8a0cf0b23e097380beaf7fc916e555fe1597a45bd0085efebc40593da66ef1408114fc6d3085467d95183
DIST ipywidgets-7.6.3.tar.gz 4072376 BLAKE2B 095226ef6a9ee0821b875dc117afe4155132b6b2d94da71b937959c1c4e9f33fa2837d8b736a47caed77c4c52fbb95d8afb5db9e58e99e567a34d6c8cf39afa3 SHA512 7b3506b43214948d73f4f2c55af81ceacff3d7cccc167dd32c72df6bffb8b1b1f8bdbfac7162d343858f723e7b3f3a1cd78f20c2f93b14a8eb39125ae2aee7b4
+DIST ipywidgets-7.6.4.tar.gz 4072522 BLAKE2B ab2c778f369fd3457b384b92680ccb77cc421cabf23907c504219fb0dfc71b10d1afee721b6430c3a4dc1a71930fb300324231a8fd55174a8b69a76f65eedfc5 SHA512 aed320f55946896469e22ab06b3a64541671f5b2e29b2b94d4339a1a108757fbafc7dc8bc9ca4d81e8cf9c4b759a95ed8f3d447aa530e85cf22899c1ad01fe3c
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.4.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.4.ebuild
new file mode 100644
index 000000000000..7ad461055ebf
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.6.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.6.3-py310.patch"
+)