summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 09:12:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 09:25:10 +0100
commitabe87084dfb8275573ab20cf620620356541e51b (patch)
tree7a694225b8b6d7de1157c0d009119fdfbdc35974 /dev-python/iso8601
parentdev-python/kombu: Bump to 5.2.1 (diff)
downloadgentoo-abe87084dfb8275573ab20cf620620356541e51b.tar.gz
gentoo-abe87084dfb8275573ab20cf620620356541e51b.tar.bz2
gentoo-abe87084dfb8275573ab20cf620620356541e51b.zip
dev-python/iso8601: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iso8601')
-rw-r--r--dev-python/iso8601/Manifest1
-rw-r--r--dev-python/iso8601/iso8601-1.0.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/iso8601/Manifest b/dev-python/iso8601/Manifest
index 591b3c15532d..4b619f9e4e59 100644
--- a/dev-python/iso8601/Manifest
+++ b/dev-python/iso8601/Manifest
@@ -1 +1,2 @@
DIST iso8601-0.1.16.tar.gz 19599 BLAKE2B ea09dc8f2d339de895e420e1efd6207b7138ba34b37186d86df099fc404a2880b146e20b904cddb69e4dbe777c56b41ad6e04191da8d2062d87b37af4e61c124 SHA512 b049de4c5fb21bca2e3183e82c86149ac7cab684ad8c7281cb8ffc2c0e53a86b00f68f260cff659c19f8814a35970462d2dbd06b21bbc42ed1507b583df7e25e
+DIST iso8601-1.0.0.tar.gz 12294 BLAKE2B 71983fdb2d47dd4699af60ee8bb31e94c1b4aab91aad6b107896429ddccc8dd087c955df812ca088667a082febd5f65fdf3c2cb10974f14e32d0f9605ce0c13b SHA512 137fdbe891889428331883c745fc341b7b066e681d7ffa339bd3484663974f35ac0d9f25eaa438603c8d982821832f8f2fddb2a3906889e62affda6d8cfb38e6
diff --git a/dev-python/iso8601/iso8601-1.0.0.ebuild b/dev-python/iso8601/iso8601-1.0.0.ebuild
new file mode 100644
index 000000000000..accfc1c9ab60
--- /dev/null
+++ b/dev-python/iso8601/iso8601-1.0.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="https://pypi.org/project/iso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris"
+
+distutils_enable_tests pytest