summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 07:34:13 +0000
committerSam James <sam@gentoo.org>2020-12-31 07:34:13 +0000
commit2c1bb549cdd4f991b50fffebfa5bb46ae2be6d54 (patch)
tree526a1389665a9a936afe00322b0737ea681f120d /dev-python/isort
parentdev-lang/rakudo: Bump (diff)
downloadgentoo-2c1bb549cdd4f991b50fffebfa5bb46ae2be6d54.tar.gz
gentoo-2c1bb549cdd4f991b50fffebfa5bb46ae2be6d54.tar.bz2
gentoo-2c1bb549cdd4f991b50fffebfa5bb46ae2be6d54.zip
Revert "dev-python/isort: cleanup old"
This reverts commit bc4f8b1b3cda6ec6ba2879dfa1883d6468241158. Still needed for Python 3.6 in some packages: * dev-python/hcloud-python * dev-python/pylama * dev-python/pylint * net-mail/hyperkitty * net-mail/postorius Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/files/isort-4.3.21_p1-tests.patch36
-rw-r--r--dev-python/isort/isort-4.3.15.ebuild15
-rw-r--r--dev-python/isort/isort-4.3.21_p2-r1.ebuild35
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 234ea6aa5d2d..5fa3daa7f3d0 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,2 +1,4 @@
+DIST isort-4.3.15.tar.gz 67949 BLAKE2B e78960518928cd74c15733bbc14bf066798ecbcc3e906754c10e352e7b88843451a1d0616d1b450100c77e95974f863951d640c9568277e867fcdfba8f44abdb SHA512 a5774d4f3c49c978e9043e52681e80011591422e60178d72074142725d9d7fa5065553686fd42bffe9e71b38b2b5bdaaa6f20e32cd8dbe33beb9431c397d78e5
+DIST isort-4.3.21_p2.tar.gz 158539 BLAKE2B 316703ca754c939e4af0db4a1060fb13a5164797a672b3faeb585a81fa0c86453fb0f1953b789661588cd0f04267a28837d46a88093a838391f752afa43e9f8b SHA512 fc2aa00c87196864864d2516b8be7acdedcf40d71d1931510e4b878dbd2b6da0b579661b50221f03f4aa5560c8bf23d5e1e10a2694d2b741ca09a92e40a4c687
DIST isort-5.6.3.tar.gz 161712 BLAKE2B ffbc2977016807d2bd5b1644377efad021af2ad27fd0e27feae1e5dfdfd112c7b5bf4b296ebf47ea6bfcbfe7f56cf3bfa8e1e7cf03963935660e678223397afb SHA512 fa2d9be306d03fc802aab3915bee2c41f4fe0c28353d9d99aa6604755e1602027cd81afca92b4302f80497c88a9dcb2701ec02ca55a5f9a2866669a68368d957
DIST isort-5.7.0.tar.gz 169353 BLAKE2B bafd6a0ce81ed80a3c1ad53ce320361ef11bc01a78211ad13b7947aafddd4d9bb5a4fbf65ec01d4c90dce7ebd0a2e3b1c4dcad729b1e27b1dd2c5c90c802eecf SHA512 ae5ff56394f495f6bd86f7581e0f8a67264671553b344b9dc2c5ba0b37f483ae500ebba9882ff5c315b913a689901b17de2eac403e0b4240f913c9e1864bab9f
diff --git a/dev-python/isort/files/isort-4.3.21_p1-tests.patch b/dev-python/isort/files/isort-4.3.21_p1-tests.patch
new file mode 100644
index 000000000000..9ece5ff6de9b
--- /dev/null
+++ b/dev-python/isort/files/isort-4.3.21_p1-tests.patch
@@ -0,0 +1,36 @@
+diff --git a/test_isort.py b/test_isort.py
+index 9d9297c..725b1e1 100644
+--- a/test_isort.py
++++ b/test_isort.py
+@@ -1539,6 +1539,7 @@ def test_custom_sections():
+ "import p24.shared.media_wiki_syntax as syntax\n")
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_glob_known():
+ """Ensure that most specific placement control match wins"""
+ test_input = ("import os\n"
+@@ -2599,6 +2600,7 @@ def test_new_lines_are_preserved():
+ os.remove(n_newline.name)
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_requirements_finder(tmpdir):
+ subdir = tmpdir.mkdir('subdir').join("lol.txt")
+ subdir.write("flask")
+@@ -2675,6 +2677,7 @@ deal = {editable = true, git = "https://github.com/orsinium/deal.git"}
+ """
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_pipfile_finder(tmpdir):
+ pipfile = tmpdir.join('Pipfile')
+ pipfile.write(PIPFILE)
+@@ -2979,6 +2982,7 @@ def test_skip_paths_issue_938(tmpdir):
+ assert b'skipped 1' in results.lower()
+
+
++@pytest.mark.skipif(sys.version_info[0] == 2, reason="Broken on Python 2")
+ def test_standard_library_deprecates_user_issue_778():
+ test_input = ('import os\n'
+ '\n'
diff --git a/dev-python/isort/isort-4.3.15.ebuild b/dev-python/isort/isort-4.3.15.ebuild
new file mode 100644
index 000000000000..fb2cabcf1a32
--- /dev/null
+++ b/dev-python/isort/isort-4.3.15.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
diff --git a/dev-python/isort/isort-4.3.21_p2-r1.ebuild b/dev-python/isort/isort-4.3.21_p2-r1.ebuild
new file mode 100644
index 000000000000..5d9e679b4968
--- /dev/null
+++ b/dev-python/isort/isort-4.3.21_p2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/-}"
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="https://github.com/timothycrosley/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-python/pipfile[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/isort-4.3.21_p1-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}