summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-11 16:01:23 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-09-16 01:37:09 -0400
commit364e49cfcd4a527086bc58b0ff2cd086756107ef (patch)
tree71d10aaede532cde2dc26734bc6ee6e1199c26a1 /dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
parentapp-admin/needrestart: remove 2.9-r0 (diff)
downloadgentoo-364e49cfcd4a527086bc58b0ff2cd086756107ef.tar.gz
gentoo-364e49cfcd4a527086bc58b0ff2cd086756107ef.tar.bz2
gentoo-364e49cfcd4a527086bc58b0ff2cd086756107ef.zip
dev-python/jaraco-collections: bump to 1.5
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-1.5.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
new file mode 100644
index 000000000000..7f21126bbb07
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the" \
+ "test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}