summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-15 09:30:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-15 09:34:36 +0100
commit1de56a68e7104245dcee85fa5d67b48a474e140e (patch)
tree29bb7e0b73ed2976688009234717919b0b55efd8 /dev-python/jaraco-stream
parentdev-python/jaraco-packaging: Bump to 8.2.1 (diff)
downloadgentoo-1de56a68e7104245dcee85fa5d67b48a474e140e.tar.gz
gentoo-1de56a68e7104245dcee85fa5d67b48a474e140e.tar.bz2
gentoo-1de56a68e7104245dcee85fa5d67b48a474e140e.zip
dev-python/jaraco-stream: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest1
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index d613377dd78a..51c1a067e8ae 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1 +1,2 @@
DIST jaraco.stream-3.0.0.tar.gz 11838 BLAKE2B 9d26ff8f78a3f090d79ccc8cbc41819a8290ebdb7770f56a57938ad9311ca1fd168d633fec78ee102c2c08156c9e0ae6f521dd5cafcb9df22928ba9f3f832734 SHA512 f2ce7e65d9a3bcd81985f45d03f7cd56b2f2939f13a423b8b65714f19eb249493d89cad774460dd08c1345124d3d10f85ce6875b5f7049705f993c0a3146e5d9
+DIST jaraco.stream-3.0.2.tar.gz 12784 BLAKE2B c9a9a1f940cd29cde67b624b0b7ac2dd426888f71d29f4bc4920eab5a7ba15713e5d5e57504e9f4f69f25d08a8cb2e2a1024c91c89b8c3aa8bb16023d84f33c6 SHA512 fce486caa9f27f3cfe7775858892d2865fe1c1656a8d369ef9321057716f25d7a737abf2a28fe7827efbeba2daa3b7992ec4fd18807751bf1fee6f48b238ab01
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.2.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.2.ebuild
new file mode 100644
index 000000000000..ddea28b787a0
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest