summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:55 +0200
commitd85f87eec4813d1f5a21d813fea4bf4cab52a1a9 (patch)
tree2045e8ee2c20ef5ac4da7995b5bac5d1809286a1 /dev-python/jaraco-stream
parentdev-python/jaraco-logging: Remove redundant versions (diff)
downloadgentoo-d85f87eec4813d1f5a21d813fea4bf4cab52a1a9.tar.gz
gentoo-d85f87eec4813d1f5a21d813fea4bf4cab52a1a9.tar.bz2
gentoo-d85f87eec4813d1f5a21d813fea4bf4cab52a1a9.zip
dev-python/jaraco-stream: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest2
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.2-r1.ebuild59
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-2.0-r1.ebuild62
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index b39cc9c57272..d613377dd78a 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1,3 +1 @@
-DIST jaraco.stream-1.2.tar.gz 7696 BLAKE2B fcc1aa8d26da17635b9ee7c68c278ae572cbe36a108cb30f5eb98c7ebfd2255aad499bed38ea044b28e820646b92e64602db0e2cdfc430169035882f7b6abe9b SHA512 47a96c1de12eb64e250c85d97429218606dc9bb212cf7b97e579763dd901ee063711c00307b7442be400856d3fd4e5994afbe1cb91a99e233541ffd7ff4024b9
-DIST jaraco.stream-2.0.tar.gz 11061 BLAKE2B 86cc9958e11421fe839551e029f839c16a12b80d329466b44224d145be6c2a15a63d03f426a9b8d1510249ea6c129e892dcfec41a32dd5c3c3a3b66acc21030f SHA512 d379d07772d739abb275cfc8ed7809583c728af695294b9d12ae1276add360b9559de64104cd20d05d82a3250237ae1f6eb23420970a95e9fdf6346ef9312331
DIST jaraco.stream-3.0.0.tar.gz 11838 BLAKE2B 9d26ff8f78a3f090d79ccc8cbc41819a8290ebdb7770f56a57938ad9311ca1fd168d633fec78ee102c2c08156c9e0ae6f521dd5cafcb9df22928ba9f3f832734 SHA512 f2ce7e65d9a3bcd81985f45d03f7cd56b2f2939f13a423b8b65714f19eb249493d89cad774460dd08c1345124d3d10f85ce6875b5f7049705f993c0a3146e5d9
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.2-r1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.2-r1.ebuild
deleted file mode 100644
index 7febc3f3bba1..000000000000
--- a/dev-python/jaraco-stream/jaraco-stream-1.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Routines for handling streaming data"
-HOMEPAGE="https://github.com/jaraco/jaraco.stream"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- <dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Skip one test which requires network access
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --ignore=jaraco/stream/test_gzip.py \
- --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/jaraco-stream/jaraco-stream-2.0-r1.ebuild b/dev-python/jaraco-stream/jaraco-stream-2.0-r1.ebuild
deleted file mode 100644
index 408604edd5c4..000000000000
--- a/dev-python/jaraco-stream/jaraco-stream-2.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Routines for handling streaming data"
-HOMEPAGE="https://github.com/jaraco/jaraco.stream"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Skip one test which requires network access
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv --ignore=jaraco/stream/test_gzip.py \
- --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}