summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-08-23 00:28:09 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-08-22 20:13:48 -0400
commit489a38f5ae08193378216aa312c00173149dc183 (patch)
treef098ef50173efb27408344ec6a0d37ac1e1390a7 /dev-python/jaraco-text/jaraco-text-1.8.ebuild
parentsys-kernel/gentoo-sources: Linux patch 3.18.40 (diff)
downloadgentoo-489a38f5ae08193378216aa312c00173149dc183.tar.gz
gentoo-489a38f5ae08193378216aa312c00173149dc183.tar.bz2
gentoo-489a38f5ae08193378216aa312c00173149dc183.zip
dev-python/jaraco-text: bump to 1.8
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/jaraco-text/jaraco-text-1.8.ebuild')
-rw-r--r--dev-python/jaraco-text/jaraco-text-1.8.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/jaraco-text-1.8.ebuild b/dev-python/jaraco-text/jaraco-text-1.8.ebuild
new file mode 100644
index 000000000000..5d53c24bb4a7
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.text"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+PDEPEND="dev-python/jaraco-collections[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-functools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}