summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-03 18:28:18 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-03 18:30:40 -0500
commit3b3c229a0d7e33fca448046760d996c392aad668 (patch)
tree54bef4c463673e689c78b2aafef0b75e6ce9d77d /dev-python/jira/jira-1.0.5.ebuild
parentdev-lang/perl: Add revbump (unkeyworded, work in progress) for adding some pa... (diff)
downloadgentoo-3b3c229a0d7e33fca448046760d996c392aad668.tar.gz
gentoo-3b3c229a0d7e33fca448046760d996c392aad668.tar.bz2
gentoo-3b3c229a0d7e33fca448046760d996c392aad668.zip
dev-python/jira: add dev-python/jira-1.0.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/jira/jira-1.0.5.ebuild')
-rw-r--r--dev-python/jira/jira-1.0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jira/jira-1.0.5.ebuild b/dev-python/jira/jira-1.0.5.ebuild
new file mode 100644
index 000000000000..98a8dad340d9
--- /dev/null
+++ b/dev-python/jira/jira-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_{2,3,4})
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="http://jira-python.readthedocs.org/en/latest/"
+SRC_URI="https://github.com/pycontribs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="filemagic ipython oauth"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ filemagic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ oauth? (
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/tlslite[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"