summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-30 09:58:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-30 10:00:03 +0200
commite537e7c83fc169f39f5eb25e9408e6609ddf2c5a (patch)
tree6fbd3672ce9a7d1147f758e7204fed2852f9335e /dev-python/jmespath/jmespath-0.9.3.ebuild
parentprofiles/arch/arm: Move global frei0r use mask mask to per-package use.stable... (diff)
downloadgentoo-e537e7c83fc169f39f5eb25e9408e6609ddf2c5a.tar.gz
gentoo-e537e7c83fc169f39f5eb25e9408e6609ddf2c5a.tar.bz2
gentoo-e537e7c83fc169f39f5eb25e9408e6609ddf2c5a.zip
dev-python/jmespath: Bump to 0.9.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/jmespath/jmespath-0.9.3.ebuild')
-rw-r--r--dev-python/jmespath/jmespath-0.9.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jmespath/jmespath-0.9.3.ebuild b/dev-python/jmespath/jmespath-0.9.3.ebuild
new file mode 100644
index 000000000000..2280da921034
--- /dev/null
+++ b/dev-python/jmespath/jmespath-0.9.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON Matching Expressions"
+HOMEPAGE="https://github.com/boto/jmespath https://pypi.python.org/pypi/jmespath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}