summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-10 19:31:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-10 20:36:08 +0200
commit447c29346ff00ba4e32053260f52debc2c1a2498 (patch)
tree9a181fb32edf279f93fe7b9b60270680e84f44eb /dev-python/josepy
parentapp-office/libreoffice-l10n: Restore 7.2.6.2 keywords (diff)
downloadgentoo-447c29346ff00ba4e32053260f52debc2c1a2498.tar.gz
gentoo-447c29346ff00ba4e32053260f52debc2c1a2498.tar.bz2
gentoo-447c29346ff00ba4e32053260f52debc2c1a2498.zip
dev-python/josepy: add 1.13.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/josepy')
-rw-r--r--dev-python/josepy/Manifest1
-rw-r--r--dev-python/josepy/josepy-1.13.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/josepy/Manifest b/dev-python/josepy/Manifest
index c8f19aa22a73..2c23eee22357 100644
--- a/dev-python/josepy/Manifest
+++ b/dev-python/josepy/Manifest
@@ -1 +1,2 @@
DIST josepy-1.12.0.tar.gz 59205 BLAKE2B 3ead71c2eb60a9bcc45615f85435f616bf6fe16c75d7e34ae5bd0f418b5b71b6ea03388198a371765e497aa29419efd9fbb2615d4546a5a8a9704acf7c9a70dd SHA512 7a5257d4a75feed65ff3abfd472e8f1c9cc81b62e27365d776d0f25e1efd94ae46374060ea463b9f04fe5e9577672bf2ab8dc8d6371cb8d01a4765921930e01b
+DIST josepy-1.13.0.tar.gz 59045 BLAKE2B e4f3caed3be0775a49d6a9c38bf6e2b61ecc50b4e3804afa9e597b741821ab63a27fe95d1592531fee7152e2076760d838f4efa50ab8b3e2f1e129c9d7457f8c SHA512 fb91946ac4bbb2a81195d200e4fdf06d40865b345005ab4ee328fd72545da2345b44c5b9ffb3115b16ffed65ab3a0c01d5b20d0d2ff3c2c2af30537a6a4721df
diff --git a/dev-python/josepy/josepy-1.13.0.ebuild b/dev-python/josepy/josepy-1.13.0.ebuild
new file mode 100644
index 000000000000..47dba8f65a48
--- /dev/null
+++ b/dev-python/josepy/josepy-1.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="JOSE protocol implementation in Python"
+HOMEPAGE="https://github.com/certbot/josepy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove coverage/flake8 options
+ sed -e '/^addopts =/d' -e '/^flake8-ignore/d' -i pytest.ini || die
+ distutils-r1_src_prepare
+}