summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:35:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:35:21 +0300
commit59085da81362fd69b33d09d16b9e7b2a5f4a57e1 (patch)
treecb530153e7f98ac14f535e6351293fef91f93b41 /dev-python/jq
parentsys-kernel/gentoo-sources: Linux version bumps (diff)
downloadgentoo-59085da81362fd69b33d09d16b9e7b2a5f4a57e1.tar.gz
gentoo-59085da81362fd69b33d09d16b9e7b2a5f4a57e1.tar.bz2
gentoo-59085da81362fd69b33d09d16b9e7b2a5f4a57e1.zip
dev-python/jq: add 1.2.1, EAPI=8, enable tests
Closes: https://bugs.gentoo.org/789066 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jq')
-rw-r--r--dev-python/jq/Manifest1
-rw-r--r--dev-python/jq/jq-1.2.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jq/Manifest b/dev-python/jq/Manifest
index b505ee76922f..93332e11d4dc 100644
--- a/dev-python/jq/Manifest
+++ b/dev-python/jq/Manifest
@@ -1,4 +1,5 @@
DIST jq-1.1.2.tar.gz 70638 BLAKE2B c22db8ebfbe74382c3b4ccda1a13c1758e5aa195c0c9f3192f1220f8948fe4747d3f83b7448089b96a9fa3a2f4167cf50b43901beabf468abb786f2a29b3b984 SHA512 5046bd61135e7547c345f2e89ee2af2f64bd370ee39e301b62c8fd9d299590305e0f9f7f6e0307f59fc6b7eb05659df82eb5bd0a162985e615eaa8d79bef58e2
DIST jq-1.1.3.tar.gz 71393 BLAKE2B 9cfdced8cad9b13179984d35e98f4094754746f1dbb23c2c0041eed7f6b5c7f348997681de8b07f59a6c6479dd6b31fa2dcdcc2f118e5cb92d5338767ea8fda2 SHA512 4aff64af748bc363917993385c8db762781f1e618a7f17c4de87fd654941c97b25d30819c0ec57695d08013f149ca9bcb58e6239d148dc719f73ecf78c41a5f0
+DIST jq-1.2.1.gh.tar.gz 10321 BLAKE2B 8bc2c88ae553dd53137c11d4f599e01398d21811a02b4f33f81aeeafa9009f58a56074c0bcadcc6382d86d2c7ada792d442f9c660787e131d0e85c95fb7cab32 SHA512 0b6dda04c0b3c63a5bf41f8a73dedc3cd889683f3e89c99cbf258c839f35f66d19a6da5cf4096148cd17a3fb1a58ba0e10d052ce46a1a18af845910e00ff5d86
DIST jq-1.6.tar.gz 1750584 BLAKE2B c9be1314e9d027247de63492ee362e996ef85faf45a47ee421cad95ebde9188bff8d3fc7db64e717ab922e1052f3b1c1500f5589fc5b2199ab66effb000e442d SHA512 5da71f53c325257f1f546a2520fe47828b495c953270df25ea0e37741463fdda72f0ba4d5b05b25114ec30f27a559344c2b024bacabf610759f4e3e9efadb480
DIST onig-6.9.4.tar.gz 908702 BLAKE2B e6e9939f284569408ba01b8551960bc939bbfdca425f8470499f5bb83ead7b6b09898f6f6a09d5d8c26d74d5416f6e5e9e2f00fbe7aa9eb820edb8aa4a3050cc SHA512 ed8f42f6893966c0ee3c168b4fdbcb04b2286ad69ecab43a754c1dbc8fc4656e01319991d776d7144b6a3f90d050781b321432278d83c74c9565c2743851c85b
diff --git a/dev-python/jq/jq-1.2.1.ebuild b/dev-python/jq/jq-1.2.1.ebuild
new file mode 100644
index 000000000000..f03da429c81e
--- /dev/null
+++ b/dev-python/jq/jq-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for jq"
+HOMEPAGE="https://github.com/mwilliamson/jq.py"
+SRC_URI="
+ https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
+ https://github.com/kkos/oniguruma/releases/download/v6.9.4/onig-6.9.4.tar.gz"
+S="${WORKDIR}/jq.py-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|import requests|#\0|' \
+ -e 's|urlretrieve(source_url, tarball_path)|shutil.copyfile(source_url, tarball_path)|' \
+ -e "s|source_url=.*kkos/oniguruma.*|source_url=\"${DISTDIR}/onig-6.9.4.tar.gz\",|" \
+ -e "s|source_url=.*stedolan/jq.*|source_url=\"${DISTDIR}/jq-1.6.tar.gz\",|" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # Cython compilation isn't part of setup.py, so do it manually
+ "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
+ distutils-r1_python_compile
+}