summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-10 23:00:33 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-10 23:10:07 +0200
commit74801f114a6cc4ab12bfc319c715ad012e06d7f7 (patch)
treeb3b4c48c99c15a31c9b7fd3c813067b0456e482e /dev-python/jq
parentdev-python/django-js-asset: add 2.0 (diff)
downloadgentoo-74801f114a6cc4ab12bfc319c715ad012e06d7f7.tar.gz
gentoo-74801f114a6cc4ab12bfc319c715ad012e06d7f7.tar.bz2
gentoo-74801f114a6cc4ab12bfc319c715ad012e06d7f7.zip
dev-python/jq: add 1.2.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jq')
-rw-r--r--dev-python/jq/Manifest1
-rw-r--r--dev-python/jq/jq-1.2.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jq/Manifest b/dev-python/jq/Manifest
index 1163d690a0cd..e447b3e60385 100644
--- a/dev-python/jq/Manifest
+++ b/dev-python/jq/Manifest
@@ -1,3 +1,4 @@
DIST jq-1.2.1.gh.tar.gz 10321 BLAKE2B 8bc2c88ae553dd53137c11d4f599e01398d21811a02b4f33f81aeeafa9009f58a56074c0bcadcc6382d86d2c7ada792d442f9c660787e131d0e85c95fb7cab32 SHA512 0b6dda04c0b3c63a5bf41f8a73dedc3cd889683f3e89c99cbf258c839f35f66d19a6da5cf4096148cd17a3fb1a58ba0e10d052ce46a1a18af845910e00ff5d86
+DIST jq-1.2.2.gh.tar.gz 10436 BLAKE2B 09514ce3a9afa8df4e61b29fc17f0d875db046ddc98332f13d702defd443e4e2ac1c612042eab82e620298d236a548625f5578d04dbeb681858bc10243c878a1 SHA512 632c5ebaf2607cc609ee4cfbdc0d68dff96e6daff916d77381f1596f3b1ca494c962cc56127376ef21fb931ab1333b666b01a599b97eab8a94416d1caec65248
DIST jq-1.6.tar.gz 1750584 BLAKE2B c9be1314e9d027247de63492ee362e996ef85faf45a47ee421cad95ebde9188bff8d3fc7db64e717ab922e1052f3b1c1500f5589fc5b2199ab66effb000e442d SHA512 5da71f53c325257f1f546a2520fe47828b495c953270df25ea0e37741463fdda72f0ba4d5b05b25114ec30f27a559344c2b024bacabf610759f4e3e9efadb480
DIST onig-6.9.4.tar.gz 908702 BLAKE2B e6e9939f284569408ba01b8551960bc939bbfdca425f8470499f5bb83ead7b6b09898f6f6a09d5d8c26d74d5416f6e5e9e2f00fbe7aa9eb820edb8aa4a3050cc SHA512 ed8f42f6893966c0ee3c168b4fdbcb04b2286ad69ecab43a754c1dbc8fc4656e01319991d776d7144b6a3f90d050781b321432278d83c74c9565c2743851c85b
diff --git a/dev-python/jq/jq-1.2.2.ebuild b/dev-python/jq/jq-1.2.2.ebuild
new file mode 100644
index 000000000000..131c11194652
--- /dev/null
+++ b/dev-python/jq/jq-1.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for jq"
+HOMEPAGE="https://github.com/mwilliamson/jq.py"
+SRC_URI="
+ https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
+ https://github.com/kkos/oniguruma/releases/download/v6.9.4/onig-6.9.4.tar.gz"
+S="${WORKDIR}/jq.py-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|import requests|#\0|' \
+ -e 's|urlretrieve(source_url, tarball_path)|shutil.copyfile(source_url, tarball_path)|' \
+ -e "s|source_url=.*kkos/oniguruma.*|source_url=\"${DISTDIR}/onig-6.9.4.tar.gz\",|" \
+ -e "s|source_url=.*stedolan/jq.*|source_url=\"${DISTDIR}/jq-1.6.tar.gz\",|" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ # Cython compilation isn't part of setup.py, so do it manually
+ "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
+ distutils-r1_python_compile
+}