summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 09:37:09 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 11:24:40 +0100
commitb5884f06a26848babfb07c7312f675caf5b0c71e (patch)
tree1e792ef64688de1516c1c548533d594241657b61 /dev-python/jsmin/jsmin-2.1.6.ebuild
parentdev-python/django-pipeline: Version Bump (diff)
downloadgentoo-b5884f06a26848babfb07c7312f675caf5b0c71e.tar.gz
gentoo-b5884f06a26848babfb07c7312f675caf5b0c71e.tar.bz2
gentoo-b5884f06a26848babfb07c7312f675caf5b0c71e.zip
dev-python/jsmin: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/jsmin/jsmin-2.1.6.ebuild')
-rw-r--r--dev-python/jsmin/jsmin-2.1.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/jsmin/jsmin-2.1.6.ebuild b/dev-python/jsmin/jsmin-2.1.6.ebuild
new file mode 100644
index 000000000000..c86327c6564b
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.1.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m ${PN}.test || die
+}