summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jsmin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jsmin')
-rw-r--r--dev-python/jsmin/Manifest3
-rw-r--r--dev-python/jsmin/jsmin-2.0.9.ebuild27
-rw-r--r--dev-python/jsmin/jsmin-2.1.1.ebuild25
-rw-r--r--dev-python/jsmin/jsmin-2.1.2.ebuild23
-rw-r--r--dev-python/jsmin/metadata.xml9
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/jsmin/Manifest b/dev-python/jsmin/Manifest
new file mode 100644
index 000000000000..0b552cb4a8f5
--- /dev/null
+++ b/dev-python/jsmin/Manifest
@@ -0,0 +1,3 @@
+DIST jsmin-2.0.9.tar.gz 7898 SHA256 04b6b05dd05b3ec27066f4274ed94e65f2f092017ee9c376a01f83de0d376dab SHA512 01478173a44ba1372a6f294f0e8b1744cce21216d8da36285735a87743c48f14415a3ac41b124aa5ca0ebc07594361d458989c1930a1cbf9c3894a594f7f9261 WHIRLPOOL 47cd4ad6b7f54f497f062b0dca16c39760e69cd3f06bde693486988d2b8744221461d588ff9ca472a4c68823aa820c7d21f4ef43aad96b1ec6605473759bac8a
+DIST jsmin-2.1.1.tar.gz 9783 SHA256 582f70f5fef561c8d561271206f45258d0c420eec31a8628914e87c73a2192e1 SHA512 1f889bb6a2916da21c315b5aff468cb8c479cbaedb99dfb4bb9298de6414615f274a4f37eeaee108a5f136ceea6893bddc5f564375bb2b2e7f14836a7f1d3dc1 WHIRLPOOL 941453d4765e983ca1b6d65a7f3afc390f967070fa8962a62ac783428071f2af70b42f5e80a4aea60dc8b0e724f490281a502cb13c58653035b34715dfe2f701
+DIST jsmin-2.1.2.tar.gz 9995 SHA256 5e710e9db14f210dfd55ebec43bca5c812d34c5b6179dbcba2e61d9f965bf4e1 SHA512 9723e2ff2feb243b84d3b8d1869a6591bbf1f3224d6f706eb7264293ed083508560586ee4466a4da370bcb4a611a48e9c78d1c25ede363312cafe9189ff97e5d WHIRLPOOL 41896e65703f45bacd0793b2ffb16c12eef4d4f012aa9c12d7282566efeafd49b3c26668c9ba2157a6112bc17d35f66f9f60430618f99dddc69e2be04be45809
diff --git a/dev-python/jsmin/jsmin-2.0.9.ebuild b/dev-python/jsmin/jsmin-2.0.9.ebuild
new file mode 100644
index 000000000000..5228709d0f35
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE="doc"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ "${PYTHON}" -m ${PN}.test || die
+ popd > /dev/null
+}
diff --git a/dev-python/jsmin/jsmin-2.1.1.ebuild b/dev-python/jsmin/jsmin-2.1.1.ebuild
new file mode 100644
index 000000000000..5b69befb33fb
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ "${PYTHON}" -m ${PN}.test || die
+ popd > /dev/null
+}
diff --git a/dev-python/jsmin/jsmin-2.1.2.ebuild b/dev-python/jsmin/jsmin-2.1.2.ebuild
new file mode 100644
index 000000000000..8c1963425862
--- /dev/null
+++ b/dev-python/jsmin/jsmin-2.1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript minifier"
+HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m ${PN}.test || die
+}
diff --git a/dev-python/jsmin/metadata.xml b/dev-python/jsmin/metadata.xml
new file mode 100644
index 000000000000..a4bede9eb394
--- /dev/null
+++ b/dev-python/jsmin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">jsmin</remote-id>
+ <remote-id type="bitbucket">dcs/jsmin</remote-id>
+ </upstream>
+</pkgmetadata>