summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:10:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:42:17 +0300
commita5ba5b15494399374f19fc068ea956d414856870 (patch)
tree7ec104d512a88c0c4c95c8b0b2512e7a69264403 /dev-python/json-rpc
parentdev-python/json5: enable py3.11 (diff)
downloadgentoo-a5ba5b15494399374f19fc068ea956d414856870.tar.gz
gentoo-a5ba5b15494399374f19fc068ea956d414856870.tar.bz2
gentoo-a5ba5b15494399374f19fc068ea956d414856870.zip
dev-python/json-rpc: EAPI=8, Use PEP517 build
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/json-rpc-1.13.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.13.0-r1.ebuild b/dev-python/json-rpc/json-rpc-1.13.0-r1.ebuild
new file mode 100644
index 000000000000..ca17c7f2c95d
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.13.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? ( dev-python/flask[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest