summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:09:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:15 +0200
commit05cff5deb84b4970c95f534141d2527afa0d6824 (patch)
tree54eddc069cd9711265a40efd061143d6fa22cc55 /dev-python/jsondiff
parentdev-python/PyPDF2: Bump to 1.27.3 (diff)
downloadgentoo-05cff5deb84b4970c95f534141d2527afa0d6824.tar.gz
gentoo-05cff5deb84b4970c95f534141d2527afa0d6824.tar.bz2
gentoo-05cff5deb84b4970c95f534141d2527afa0d6824.zip
dev-python/jsondiff: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-2.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index 2a8adda09ae7..fc9ef7acb6af 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1 +1,2 @@
DIST jsondiff-1.3.1.gh.tar.gz 15457 BLAKE2B f3896c85b601ac32859e59f2a5a29b51f124a1dd27fa2b0da40e44c4b776bbba933043fb7334e5ec20833eea25143d40cc7988a8308f56eff20510db982688b0 SHA512 cbbed17bf00f1757d81477e02435c3f5a9a3246774f3fd9a433be31de1617525acfe33d6790be33dcf9b5da5ef3d6910d13958fb7b8ea4fbd802c74485a9dc6f
+DIST jsondiff-2.0.0.gh.tar.gz 15405 BLAKE2B d69e5a9316e8ce32c6fd3e62162b609a471ff57bacb77f47a192b85352e77135a37c964d0ade5df4b4e37fe7d996eab13649dd4c6a3bc3fc0479294f840c82f9 SHA512 ca266040294c064b499763174613628125a9d426f37eddb8f63806d5774ce8828d514ca30ea4b42f6e2529aa34344c601ece05b6c1b42dcedd71c7b62ed0afba
diff --git a/dev-python/jsondiff/jsondiff-2.0.0.ebuild b/dev-python/jsondiff/jsondiff-2.0.0.ebuild
new file mode 100644
index 000000000000..901fc3049256
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/
+"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}