summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jsonrpclib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest2
-rw-r--r--dev-python/jsonrpclib/files/jsonrpclib-fix-nested-imports.patch31
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild27
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild27
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild27
-rw-r--r--dev-python/jsonrpclib/metadata.xml12
6 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
new file mode 100644
index 000000000000..89517e2d2795
--- /dev/null
+++ b/dev-python/jsonrpclib/Manifest
@@ -0,0 +1,2 @@
+DIST jsonrpclib-0_pre20110820.tar.bz2 14608 SHA256 a31ce391e8f430f2434c538dedb012e879296628a7b2968f1aa41cb36207369d SHA512 80864890982c4a11996cd9fae21029cdf40b089eb6c2d265c645f52fe0a6e858b3405c5d899d2a5908527da04263d93064f365c5308adda1791105bf32329b71 WHIRLPOOL d7ad4277ea5bcb3451728a36f42a76e965256ac6239269e12125c1a19f9dbbeb9dfe69b58738b42e7823a687ad195f8a782aa2e0fe4797a59743b5230f598365
+DIST jsonrpclib-0_pre20150305.tar.xz 14948 SHA256 392ad1643d5455f3b9d08414ca3827edad7b4d189376203c2ccc2980e807aba1 SHA512 091bb753469b5983d68631d8acebea6e9b208b01758a08f948a63b9d022ab2ce072ceee259a6747645dadf9a02ca77185fd5cdde3d1635addedc402629e1c381 WHIRLPOOL 6d2967d4f5c6decd24c27dbc9f298e550a99873d1657618ed4742f4f9aefe1e9ca1cc660702a786d42463d3853df0cd0644d972810c7369cf56d309925df6780
diff --git a/dev-python/jsonrpclib/files/jsonrpclib-fix-nested-imports.patch b/dev-python/jsonrpclib/files/jsonrpclib-fix-nested-imports.patch
new file mode 100644
index 000000000000..39e0463c91e7
--- /dev/null
+++ b/dev-python/jsonrpclib/files/jsonrpclib-fix-nested-imports.patch
@@ -0,0 +1,31 @@
+From 865a813078c1b447713aeb1f1bb860c441a88365 Mon Sep 17 00:00:00 2001
+From: Jon Salz <jsalz@chromium.org>
+Date: Fri, 20 Apr 2012 02:41:50 +0800
+Subject: [PATCH] Fix importing of nested modules.
+
+https://github.com/joshmarshall/jsonrpclib/issues/15
+---
+ jsonrpclib/jsonclass.py | 7 +++++++
+ 1 files changed, 7 insertions(+), 0 deletions(-)
+
+diff --git a/jsonrpclib/jsonclass.py b/jsonrpclib/jsonclass.py
+index 298c3da..1d86d5f 100644
+--- a/jsonrpclib/jsonclass.py
++++ b/jsonrpclib/jsonclass.py
+@@ -129,6 +129,13 @@ def load(obj):
+ except ImportError:
+ raise TranslationError('Could not import %s from module %s.' %
+ (json_class_name, json_module_tree))
++
++ # The returned class is the top-level module, not the one we really
++ # want. (E.g., if we import a.b.c, we now have a.) Walk through other
++ # path components to get to b and c.
++ for i in json_module_parts[1:]:
++ temp_module = getattr(temp_module, i)
++
+ json_class = getattr(temp_module, json_class_name)
+ # Creating the object...
+ new_obj = None
+--
+1.7.3.4
+
diff --git a/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild b/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild
new file mode 100644
index 000000000000..fd26d3b99f9d
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="amd64 arm x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
diff --git a/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild b/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild
new file mode 100644
index 000000000000..101ea1209ee4
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0_pre20150305.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
new file mode 100644
index 000000000000..101ea1209ee4
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
diff --git a/dev-python/jsonrpclib/metadata.xml b/dev-python/jsonrpclib/metadata.xml
new file mode 100644
index 000000000000..93833cfa1fae
--- /dev/null
+++ b/dev-python/jsonrpclib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ <description>make whatever changes you want</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">joshmarshall/jsonrpclib</remote-id>
+ </upstream>
+</pkgmetadata>