summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-02-09 16:47:34 -0800
committerPatrick McLean <chutzpah@gentoo.org>2016-02-09 16:47:34 -0800
commit127cc8df2c5e4bc87d74fa2a27c1a3e077db0557 (patch)
tree3a3324945d7fba8377d371686728c1df7308d5c8 /dev-python/jsonschema
parentdev-util/yuicompressor: Fix several problems with 2.4.8-r1 (diff)
downloadgentoo-127cc8df2c5e4bc87d74fa2a27c1a3e077db0557.tar.gz
gentoo-127cc8df2c5e4bc87d74fa2a27c1a3e077db0557.tar.bz2
gentoo-127cc8df2c5e4bc87d74fa2a27c1a3e077db0557.zip
dev-python/jsonschema: Revision bump, make functools32 dep dependant on python2, again
Somehow this got dropped since last time made this change. Currently this bombs out on python3 only systems since functools32 is <python3.2 only. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild b/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..a3ad87904859
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.python.org/pypi/jsonschema http://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/rfc3986[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/functools32[${PYTHON_USEDEP}]' 'python2*' pypy)
+ "
+DEPEND="${RDEPEND}
+ dev-python/vcversioner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}