summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jsonschema
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest2
-rw-r--r--dev-python/jsonschema/jsonschema-2.3.0.ebuild25
-rw-r--r--dev-python/jsonschema/jsonschema-2.4.0.ebuild22
-rw-r--r--dev-python/jsonschema/metadata.xml15
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
new file mode 100644
index 000000000000..91c16cd0ec49
--- /dev/null
+++ b/dev-python/jsonschema/Manifest
@@ -0,0 +1,2 @@
+DIST jsonschema-2.3.0.tar.gz 43115 SHA256 a79dcee3769d7cf749836da840966a83cd2e33e361264e77b74df9490ffe5c89 SHA512 8c39c47c236904d3deb3893d43fd1a9332896e8a1883901ef6040607575250b0d661b010d94be6b0d52515b42e2c7924c93d352ca9b209cec54514e856d95c75 WHIRLPOOL 7f61838ac7173ac2d0dde16f83a864b8dcd82905d139c4de8d7b698ce022f1a63003ff45be53cf134a30747533cb034d2d5d944559a1b6990a37d8073b38d0ea
+DIST jsonschema-2.4.0.tar.gz 48293 SHA256 1298a2f1b2f4c4a7b921cccd159e4e42f6d7b0fb75c86c0cdecfc71f061833fa SHA512 111d60f6b490c016a69bed6b0b22cc6395c949d4510fdcb530757d6e61720cd2e1e3346293a5dd1b6501b262b36510ec08ab4ed76dc7484065e692e041232a93 WHIRLPOOL 1bcec6c3e09f72ad314db49e73d92f854e5f69c490e9ad46b4d0e31564392fb27bf387eec6d376237735396a7da989dcd601e33e2a43e35ed2559fc83b7ebf63
diff --git a/dev-python/jsonschema/jsonschema-2.3.0.ebuild b/dev-python/jsonschema/jsonschema-2.3.0.ebuild
new file mode 100644
index 000000000000..f8a5a6a1ca28
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-2.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}} pypy)
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="http://pypi.python.org/pypi/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+python_test() {
+ local runner=( "${PYTHON}" -m unittest )
+ if [[ ${EPYTHON} == python2.6 || ${EPYTHON} == python3.1 ]]; then
+ unset PYTHONPATH
+ runner=( unit2.py )
+ fi
+ "${runner[@]}" discover || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/jsonschema/jsonschema-2.4.0.ebuild b/dev-python/jsonschema/jsonschema-2.4.0.ebuild
new file mode 100644
index 000000000000..2a51cbaebb8c
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-2.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="http://pypi.python.org/pypi/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/jsonschema/metadata.xml b/dev-python/jsonschema/metadata.xml
new file mode 100644
index 000000000000..31179ec4c84f
--- /dev/null
+++ b/dev-python/jsonschema/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+jsonschema is an implementation of JSON Schema (currently in Draft 3) for
+Python (supporting 2.6+ including Python 3).
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">jsonschema</remote-id>
+ </upstream>
+</pkgmetadata>