summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-03-09 14:17:19 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-03-09 14:17:19 +0300
commitba3bcd35aaa9e29a9c702cb3744d8ba5f907aa04 (patch)
tree70b00801f20cf6935a248e4c240e8edfcd4eca7e /dev-python/jsonschema
parentsys-libs/glibc: make stack protection optional, bug #679788 (diff)
downloadgentoo-ba3bcd35aaa9e29a9c702cb3744d8ba5f907aa04.tar.gz
gentoo-ba3bcd35aaa9e29a9c702cb3744d8ba5f907aa04.tar.bz2
gentoo-ba3bcd35aaa9e29a9c702cb3744d8ba5f907aa04.zip
dev-python/jsonschema: Version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-3.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index b8766eefa6ce..d6c1ad4aee28 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -2,3 +2,4 @@ DIST jsonschema-2.3.0.tar.gz 43115 BLAKE2B 1ae30621c95d5cddb038b244220e9df02d6a3
DIST jsonschema-2.4.0.tar.gz 48293 BLAKE2B a3e4ddece8550dde833fb447aefe1e22db6e945b2f7bc01e1b969868480dc516ac0cb79b701d265f6996d892dbaed10ecf3e91ec8772ba5fdd2b6b8ad034fc0a SHA512 111d60f6b490c016a69bed6b0b22cc6395c949d4510fdcb530757d6e61720cd2e1e3346293a5dd1b6501b262b36510ec08ab4ed76dc7484065e692e041232a93
DIST jsonschema-2.5.1.tar.gz 50855 BLAKE2B 552c8878aff8f67db6011abfcbda73efac82b557c2e7d0ed7fca755e51ab263816931e8c6e69ea43356257d25efabedc5bac135d1477534184d3783714bf2b8f SHA512 9e8f6ce16504b7ae7ef1ceb44ecb07eab85923e40967bd8e502b9fa779e772b547db90f56ca951d06591b951e7240db1071e909ac75543d42f6f2495f6de3298
DIST jsonschema-2.6.0.tar.gz 53252 BLAKE2B 38d2d1d9f91e923e66aa44fede2597b129813b18b39133da1935758dc651a0e567515e8b97bbd0cb4f0a2cb652c635446aa3dd4026066dc3d996e32a33495af5 SHA512 03f916abd023b32fbe60f91718d6f2f94d8834bd1bd8ec85ab02f591a145161275c2cde25b037c4d2e94703b870159feb776d3556f011e4c394d2e20ab897b0b
+DIST jsonschema-3.0.1.tar.gz 120834 BLAKE2B f99d77847a697bb28bac39b7b9a2c6c80cf93eb09a5d585e1f734ebe7d1bdb732b8fcd0c945106ac55c6d64a236def0e1d803a18a2df5e27322a2452ce99a55d SHA512 564e7385728b15387cd44c06cf50c36342fe4c6f497d208ce3d611d1659023e95ff032b2609a786cd9610bd915f878d138eef47913f18cc56eaae0651eb6efe8
diff --git a/dev-python/jsonschema/jsonschema-3.0.1.ebuild b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
new file mode 100644
index 000000000000..5550535fb8d9
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/functools32[${PYTHON_USEDEP}]' 'python2*' pypy)
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/vcversioner-2.16.0.0[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}