summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-14 13:36:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-14 14:01:13 +0200
commit0ebbc1f23e26d4a1e5823e908943a98278fb4060 (patch)
tree5f5a02491b942f3da4c4a1f0bda0b8d4091bce25 /dev-python/jupyter_client
parentdev-python/hypothesis: Bump to 5.19.2 (diff)
downloadgentoo-0ebbc1f23e26d4a1e5823e908943a98278fb4060.tar.gz
gentoo-0ebbc1f23e26d4a1e5823e908943a98278fb4060.tar.bz2
gentoo-0ebbc1f23e26d4a1e5823e908943a98278fb4060.zip
dev-python/jupyter_client: Bump to 6.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index ed48986c4316..3ebe5a7361dd 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-5.3.4.tar.gz 275850 BLAKE2B a0884fb6cd2858b3ecf8353c6dc180370a53b4d59f77fdeb33c972c72857650e2e8b64ac5f6c9d223a99f30bb9ad9e06673cfe14b2d79abc0e4363104ffd15c3 SHA512 54b5206c08f5119feb50deb2d815d79a178799ad5c1231a0d03fc950ebbf6cb2f7c3a757024f788d416f808c57aa8476fcfa110f63182314bf2d5cdeb9a006cf
DIST jupyter_client-6.1.5.tar.gz 290829 BLAKE2B 7029703ebf7dccafd9c90835d9ed3305f591597947dabaef3fd670c7fd595bc8a8fa5258ad07b0bbe170c134f8f50593e980c2360de2521216fc061996268032 SHA512 b289b07f1300a7aa541b15ece33340fde7dd9765a200214668ad3a124ec7fd98c742f61417c9d31d6daff9ecc1aaaca6ec516f359cc26007731c0f8d859a73a9
+DIST jupyter_client-6.1.6.tar.gz 292265 BLAKE2B 46f5b814577c8b1351ce42eb3de4a3032bb2917512f0c9cfc07fddc991698e192b628c03a9ce0d98817dfebcf4af0386fa4ee656b524f54c36de64781af3b8dd SHA512 9a443a2b4a86d823d1403a05d359b50ca95efb8e1dd992d331699e3fe2b46e5d4190cc55aa5d110a384fc0bb94abceaa4e36f67c0f7ce5a33f9ef3b11e682522
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.6.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.6.ebuild
new file mode 100644
index 000000000000..2bf01c589f1a
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest