summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-20 08:01:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-20 09:16:55 +0200
commit375123a01485ed6d80b39f70708815707d3c1153 (patch)
tree31e6084cf5910b4153d73f3ca66c6ddb9a8902a0 /dev-python/jupyter_client
parentdev-python/hypothesis: Bump to 6.14.9 (diff)
downloadgentoo-375123a01485ed6d80b39f70708815707d3c1153.tar.gz
gentoo-375123a01485ed6d80b39f70708815707d3c1153.tar.bz2
gentoo-375123a01485ed6d80b39f70708815707d3c1153.zip
dev-python/jupyter_client: Bump to 7.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index c085884a134e..14177c84763d 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-6.1.12.tar.gz 301499 BLAKE2B 8041b84ad2e89413ee60d1aee2e49a67a89b5aad1c3118c8fa7d7d719c8ec2acbc72278c9aaea095cdcb89235800d09b1792b2138c09a4aad59ceaaf695af431 SHA512 f31ff1a24b264c32d35d07491785e1d77935cdb463243e90e4aadcb0a093a074cdce75f01662591766588f39b146077639ca697f71157309dc92f12ae04d5cdd
DIST jupyter_client-7.0.0.tar.gz 317271 BLAKE2B 446b0b5dfea840a2faf25445217d870654836cd1e63057d9fb8e596960da1528684ec51b452d1059ab83317ff9da3c65cf5c8b14c3f2cfbba7dbcfdeec0e31b5 SHA512 dadcd06a4c63e441c60edc9fb8ed49d14a1309822042d7f8cbc48943d394da720117ca829fe38e419f775025cdb01227e47f077f89f8ce5403efbeb1a1d1ef2c
+DIST jupyter_client-7.0.1.tar.gz 317467 BLAKE2B bcaa4f58071e0c90e81afb010a10ad221793a186aba0e7ae233538c810b787e3a0bc734735cd20750500c9d74d6c5f548f7deaf3daa3e989d75b5f9cbb5344ee SHA512 5665018294e87b0ae0fe58a7281e205e1668c3676f7092128f4c6ce8eb13e53983fc888508e913085beb29b13b1aa46307c4bf1c8c25bfe1f9efcfb7254bdf3a
diff --git a/dev-python/jupyter_client/jupyter_client-7.0.1.ebuild b/dev-python/jupyter_client/jupyter_client-7.0.1.ebuild
new file mode 100644
index 000000000000..1ea8114ff2d4
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.0[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.1[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_signal_kernel_subprocesses
+ jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_async_signal_kernel_subprocesses
+ )
+ epytest ${deselect[@]/#/--deselect }
+}