summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-09 08:41:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-09 09:23:15 +0200
commitd0cc5eda3130c965b009f4d204069a56127f1c01 (patch)
tree3ca1560d8fd826f29dedc38746e2e1858f0271cb /dev-python/jupyter_client
parentdev-python/cssutils: Bump to 2.4.2 (diff)
downloadgentoo-d0cc5eda3130c965b009f4d204069a56127f1c01.tar.gz
gentoo-d0cc5eda3130c965b009f4d204069a56127f1c01.tar.bz2
gentoo-d0cc5eda3130c965b009f4d204069a56127f1c01.zip
dev-python/jupyter_client: Bump to 7.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.3.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 50c98e15393f..1d0fd3b667d6 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_client-7.3.1.tar.gz 328697 BLAKE2B 9bdca39d974c21e1674f58a7aaa51a6b96e4dc307f918aacc403146827df5ad7a867243dd2df95e717ab7ebd62367817e4f43cae562f47147b4271d72240600e SHA512 86a98288f1be5321b8495d78770501ca45fe3139a482ec41606253eef69eaf4d3f284d1c373d9df64efe28428f32cd1a3b19842a7331b3ac200d780e7a786407
DIST jupyter_client-7.3.2.tar.gz 328943 BLAKE2B 9093278ec2aeff9810bb0af86607185776d940e51ade5194c28800b1e08a1b40d4a020f947b4fac092e26e6a6b1b1eabe4b2c025d955f4ed1ddf3cd190dda96a SHA512 ec0ceb518eae63356058032b2e43979c78a691eefe594ef98767daff27ea88d4363bdc8f7c4e66c549fd5e7a5fdb0b538d58a45f7d73145093f7bbe26df03c71
DIST jupyter_client-7.3.3.tar.gz 329130 BLAKE2B 7a60e8a0f4142198efc35f09378e3d35e3985b1531c3a759b7f3b4373c8df4dc76d56a28298f9f2972a4ba323e6d7a1b0c49d2dacdc490019da63692324d1ee1 SHA512 8a89f7e95f8f7f87ebc5ed362508cf5368c6e611c0291a56f72acafeb6ec85ad50e943133d178486605ad325dfc4e3b8231888b8dff0b0cc14b0e707b126f1d3
+DIST jupyter_client-7.3.4.tar.gz 329871 BLAKE2B 34f4cc01ced39e30f81e0c7524ada9319f7bea6fb0f941dad85ac3f969de71b68bde22359a9d343df84432e320994a8c4c4aa9ebd390b841e4b18042ac6f0b14 SHA512 3bb1fd7c93e16c03db0c249810fe48428dc9c1fa24ae885a3d30b4ac2d2e980f48edc06c2c6065b3e8f91610bf5bc7500854986f55c18bd9f695f192aa470beb
diff --git a/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild b/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild
new file mode 100644
index 000000000000..8b28df440476
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.3.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest