summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:56:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:57:54 +0100
commitf1528904b9ad123f114b0233e4d22a7fe838bbff (patch)
tree92ecb2be5e7039f7a867f795983af1bf564b321e /dev-python/jupyter_client
parentdev-python/jsonpickle: Remove old (diff)
downloadgentoo-f1528904b9ad123f114b0233e4d22a7fe838bbff.tar.gz
gentoo-f1528904b9ad123f114b0233e4d22a7fe838bbff.tar.bz2
gentoo-f1528904b9ad123f114b0233e4d22a7fe838bbff.zip
dev-python/jupyter_client: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest2
-rw-r--r--dev-python/jupyter_client/files/jupyter_client-6.1.6-msgpack-1.patch28
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.10.ebuild35
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild38
4 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 4a81c337adee..05523cebb23e 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,3 +1 @@
-DIST jupyter_client-6.1.10.tar.gz 293620 BLAKE2B 87052ae5b07195a6a51d6308b06d0543850e23a7494602c61811270b8eea619b9337ee0e9069f9d905f1397aa5fc48710b5a894b21fb0328d397168508d34dbc SHA512 8a6d63b95e95e3230882ea67892fe87a24b43d0e85aa910ff8056c2067bb2bc2640d1896f851d0441234f9db27c2a876925988d141b2ed35287ae3e0e5b1eacb
DIST jupyter_client-6.1.11.tar.gz 293651 BLAKE2B 73a8567927c452a6a6a591eed04d592c6bb52211214e6d27ae816a2ce07a61c3f80991a2209b42c1d679ff6d3ead564f6ac97e6500473e0e5bd86bad83db07c1 SHA512 3cd6c3d299ea7097b04ad88b08dad8c23d90c5feee18bf441434a6069151b85717c4d00d2c186c463995d26383442c4f63c86565b1606e60afb61426515f9a11
-DIST jupyter_client-6.1.6.tar.gz 292265 BLAKE2B 46f5b814577c8b1351ce42eb3de4a3032bb2917512f0c9cfc07fddc991698e192b628c03a9ce0d98817dfebcf4af0386fa4ee656b524f54c36de64781af3b8dd SHA512 9a443a2b4a86d823d1403a05d359b50ca95efb8e1dd992d331699e3fe2b46e5d4190cc55aa5d110a384fc0bb94abceaa4e36f67c0f7ce5a33f9ef3b11e682522
diff --git a/dev-python/jupyter_client/files/jupyter_client-6.1.6-msgpack-1.patch b/dev-python/jupyter_client/files/jupyter_client-6.1.6-msgpack-1.patch
deleted file mode 100644
index 34a95d04ac78..000000000000
--- a/dev-python/jupyter_client/files/jupyter_client-6.1.6-msgpack-1.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From bb973fa33952c1a803097852c031b3979dae607c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 22 Dec 2020 09:38:13 +0100
-Subject: [PATCH] Fix test_session with msgpack-1
-
-Replace the encoding parameter with raw=False to fix test_session
-with msgpack-1.0.0+. The encoding parameter was already deprecated
-in msgpack-0.6.2, and raw=False is compatible with that version too.
----
- jupyter_client/tests/test_session.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/jupyter_client/tests/test_session.py b/jupyter_client/tests/test_session.py
-index d0ec662..45be9a9 100644
---- a/jupyter_client/tests/test_session.py
-+++ b/jupyter_client/tests/test_session.py
-@@ -304,7 +304,7 @@ class TestSession(SessionTestCase):
-
- session = ss.Session(
- pack=msgpack.packb,
-- unpack=lambda buf: msgpack.unpackb(buf, encoding='utf8'),
-+ unpack=lambda buf: msgpack.unpackb(buf, raw=False),
- )
- self._datetime_test(session)
-
---
-2.29.2
-
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild
deleted file mode 100644
index 3b7ac8d7e06b..000000000000
--- a/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/async_generator[${PYTHON_USEDEP}]
- <dev-python/jedi-0.17.3[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
deleted file mode 100644
index 50c5df6246e6..000000000000
--- a/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-msgpack-1.patch
-)