summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:44:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:46 +0100
commitf783485027ed2ff434d527ea8f724607c7da4c8a (patch)
treeadcdc6772633cdd52ea3fbd23406d6d271752244 /dev-python/jupyter_client
parentdev-python/tox: Bump to 3.21.0 (diff)
downloadgentoo-f783485027ed2ff434d527ea8f724607c7da4c8a.tar.gz
gentoo-f783485027ed2ff434d527ea8f724607c7da4c8a.tar.bz2
gentoo-f783485027ed2ff434d527ea8f724607c7da4c8a.zip
dev-python/jupyter_client: Bump to 6.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 366d8f094858..a3f87c83a383 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
+DIST jupyter_client-6.1.10.tar.gz 293620 BLAKE2B 87052ae5b07195a6a51d6308b06d0543850e23a7494602c61811270b8eea619b9337ee0e9069f9d905f1397aa5fc48710b5a894b21fb0328d397168508d34dbc SHA512 8a6d63b95e95e3230882ea67892fe87a24b43d0e85aa910ff8056c2067bb2bc2640d1896f851d0441234f9db27c2a876925988d141b2ed35287ae3e0e5b1eacb
DIST jupyter_client-6.1.6.tar.gz 292265 BLAKE2B 46f5b814577c8b1351ce42eb3de4a3032bb2917512f0c9cfc07fddc991698e192b628c03a9ce0d98817dfebcf4af0386fa4ee656b524f54c36de64781af3b8dd SHA512 9a443a2b4a86d823d1403a05d359b50ca95efb8e1dd992d331699e3fe2b46e5d4190cc55aa5d110a384fc0bb94abceaa4e36f67c0f7ce5a33f9ef3b11e682522
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild
new file mode 100644
index 000000000000..3b7ac8d7e06b
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.17.3[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest