summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-07 07:30:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-07 08:54:03 +0200
commitfa3ba3072c1cecf90d8aac65c38ae0384383a6b4 (patch)
treef54d856bf706104057ee8120b9fc18f42c629cd4 /dev-python/jupyter_client
parentdev-python/ipykernel: Bump to 6.13.1 (diff)
downloadgentoo-fa3ba3072c1cecf90d8aac65c38ae0384383a6b4.tar.gz
gentoo-fa3ba3072c1cecf90d8aac65c38ae0384383a6b4.tar.bz2
gentoo-fa3ba3072c1cecf90d8aac65c38ae0384383a6b4.zip
dev-python/jupyter_client: Bump to 7.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.3.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index acbeb7f7bafd..1f36dddedf8b 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-7.3.1.tar.gz 328697 BLAKE2B 9bdca39d974c21e1674f58a7aaa51a6b96e4dc307f918aacc403146827df5ad7a867243dd2df95e717ab7ebd62367817e4f43cae562f47147b4271d72240600e SHA512 86a98288f1be5321b8495d78770501ca45fe3139a482ec41606253eef69eaf4d3f284d1c373d9df64efe28428f32cd1a3b19842a7331b3ac200d780e7a786407
+DIST jupyter_client-7.3.2.tar.gz 328943 BLAKE2B 9093278ec2aeff9810bb0af86607185776d940e51ade5194c28800b1e08a1b40d4a020f947b4fac092e26e6a6b1b1eabe4b2c025d955f4ed1ddf3cd190dda96a SHA512 ec0ceb518eae63356058032b2e43979c78a691eefe594ef98767daff27ea88d4363bdc8f7c4e66c549fd5e7a5fdb0b538d58a45f7d73145093f7bbe26df03c71
diff --git a/dev-python/jupyter_client/jupyter_client-7.3.2.ebuild b/dev-python/jupyter_client/jupyter_client-7.3.2.ebuild
new file mode 100644
index 000000000000..f5f42b66bafa
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # relax pyzmq dep
+ sed -i -e '/pyzmq/s:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}