summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2019-12-16 09:39:11 +0100
committerBenda Xu <heroxbd@gentoo.org>2019-12-23 19:53:23 +0800
commit64ebb485c38598ecede514adb27a4ee47206bc10 (patch)
tree3d410106b5fe6301f57537db1ec2dfb8a15638f5 /dev-python/jupyter_core/jupyter_core-4.6.1.ebuild
parenteclass/tests/flag-o-matic.sh: clarify the filter (diff)
downloadgentoo-64ebb485c38598ecede514adb27a4ee47206bc10.tar.gz
gentoo-64ebb485c38598ecede514adb27a4ee47206bc10.tar.bz2
gentoo-64ebb485c38598ecede514adb27a4ee47206bc10.zip
dev-python/jupyter_core: Version bump 4.6.1
Employ `distutils_enable_tests pytest`. Bug: https://bugs.gentoo.org/702458 Bug: https://github.com/gentoo/gentoo/pull/13988 Closes: https://github.com/gentoo/gentoo/pull/14003 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org> Package-Manager: Portage-2.3.81, Repoman-2.3.20
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.6.1.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.6.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.6.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.6.1.ebuild
new file mode 100644
index 000000000000..ce543358ebbb
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+ test? ( >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}