summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-01 09:25:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-01 09:50:47 +0100
commit38e2e9eb8fb16f2bb2a1b79289a58d314560cfc3 (patch)
tree609634f3e74d72a31023c04ce5c70d1a9d2ca0bc /dev-python/jupyter_core
parentdev-python/llfuse: Bump to 1.4.1 (diff)
downloadgentoo-38e2e9eb8fb16f2bb2a1b79289a58d314560cfc3.tar.gz
gentoo-38e2e9eb8fb16f2bb2a1b79289a58d314560cfc3.tar.bz2
gentoo-38e2e9eb8fb16f2bb2a1b79289a58d314560cfc3.zip
dev-python/jupyter_core: Bump to 4.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.7.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index ca7f2d8eb8ae..7fa3df2c9901 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.6.3.tar.gz 67305 BLAKE2B 7c6a32bd8ce773b7bc4156eabf75597112716632179736b19be4b0e73eba7c5c67a0c9d2d141b952d72b68aff826227b0004a3bc9f3b286b68eb1375f2316bdb SHA512 3c7370c24a4cf53c9747e9e411852d207c0c7035809dab7cb018ccb53e19208df25ad4f728531e47f3a42c4d9694c3e1ed7b03133de23bcbdeb346c319f5f51f
+DIST jupyter_core-4.7.1.tar.gz 68886 BLAKE2B aa89351845c669474c03a307934a5d84b6357679bc99f2fc7da4f93ff347766d52ce3551780803b73941d6457f7004306e795398fd390c81e9180193a2119225 SHA512 bc190abd000566dbd097dcb14acf1926c92bb265f2cfbbd14dac6a9cf7d6a02f924ba89fa957ca30c2af57433e9187e288bb8e80d039a3d3a583c6e488a9c80e
diff --git a/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
new file mode 100644
index 000000000000..3ee1504526a9
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.7.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # fails if jupyter is not in system sitedir
+ # (PYTHONPATH is insufficient)
+ jupyter_core/tests/test_command.py::test_not_on_path
+ jupyter_core/tests/test_command.py::test_path_priority
+ # TODO
+ jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}