summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 15:09:05 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-25 15:09:56 +0200
commit8046c0ed7ccd12d95ad1cdc3d8230f2b61cb1555 (patch)
treedfb3d452a6c52b41bfea53ceabf73f316c690410 /dev-python/jupyter_packaging
parentdev-python/jupyter-lsp: add version 1.5.0 (diff)
downloadgentoo-8046c0ed7ccd12d95ad1cdc3d8230f2b61cb1555.tar.gz
gentoo-8046c0ed7ccd12d95ad1cdc3d8230f2b61cb1555.tar.bz2
gentoo-8046c0ed7ccd12d95ad1cdc3d8230f2b61cb1555.zip
dev-python/jupyter_packaging: add version 0.11.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_packaging')
-rw-r--r--dev-python/jupyter_packaging/Manifest1
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_packaging/Manifest b/dev-python/jupyter_packaging/Manifest
index a3f61b4140db..da0e6c116979 100644
--- a/dev-python/jupyter_packaging/Manifest
+++ b/dev-python/jupyter_packaging/Manifest
@@ -1 +1,2 @@
DIST jupyter_packaging-0.10.6.tar.gz 21836 BLAKE2B 921e763e11c3973442fa819559d921618aab4010ae7cd4ca3314acb53c7fd7be68f10af46b4d0c9888d2648c0e28565c22ad47270a9d9a1c950640b38a2a1078 SHA512 1b59219dc14c3e44c0f100e9a46b614a8c4395fc26937622515e82f4ffa35c29d8101d6f56a3d496da9279e1e7fc58a91af83bca2b50875afaf1745706ce466d
+DIST jupyter_packaging-0.11.0.tar.gz 21847 BLAKE2B 61e637a0c47b117d42441343bf562f92d665abe0f5111588c91ef65b54e04d5c2878f13b9221128abf7e44070678cb878279a7227511c232d42161a159fd7f21 SHA512 35a5682ef99848f6f22b3cd2abeceaff81d575618ff670bcc664ca0bb77857b38c456a23c03787e9ca23a27901e5456c8417722163385da23efc9b85c15e015a
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild
new file mode 100644
index 000000000000..6440233f72bb
--- /dev/null
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.11.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Tools to help build and install Jupyter Python packages"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO: package "build"
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+
+ # broken by Gentoo pip patch
+ # TODO: retry when we finally make the patch less intrusive
+ tests/test_datafiles_install.py
+ tests/test_install.py
+ )
+
+ distutils_install_for_testing --via-venv
+ epytest ${deselect[@]/#/--deselect }
+}