summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-09 07:48:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-09 07:51:27 +0200
commitcbe6efd43b3d16c13327f5d0997f411c59a84bb0 (patch)
tree150411f0fec74751e3230dc9397ffe833bab9579 /dev-python/jupyter_server
parentdev-python/inflect: Remove old (diff)
downloadgentoo-cbe6efd43b3d16c13327f5d0997f411c59a84bb0.tar.gz
gentoo-cbe6efd43b3d16c13327f5d0997f411c59a84bb0.tar.bz2
gentoo-cbe6efd43b3d16c13327f5d0997f411c59a84bb0.zip
dev-python/jupyter_server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_server')
-rw-r--r--dev-python/jupyter_server/Manifest1
-rw-r--r--dev-python/jupyter_server/jupyter_server-1.18.0.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/jupyter_server/Manifest b/dev-python/jupyter_server/Manifest
index 7ac7a21f298a..4cd01ec114aa 100644
--- a/dev-python/jupyter_server/Manifest
+++ b/dev-python/jupyter_server/Manifest
@@ -1,2 +1 @@
-DIST jupyter_server-1.18.0.tar.gz 450132 BLAKE2B a378ba3bfdc629d05478c33365b2d6df893b9ce1dc3ce26c78efcbd69b42441ff730ca58a83fb87446d073f849ce5a6c725784a15953fe9bdae119e529fe30c8 SHA512 5a194a9811162774990b125020d75c134ca32ab916c046cf0345a3959868ab7b293c0659bd54c2da91ef5e8bbb9b433f9a6c16d829277d0f34e924c6332fa6c0
DIST jupyter_server-1.18.1.tar.gz 451117 BLAKE2B ac9088f8f5c5afa6455f41b4006c0d49286006574101b42dd8e28501c97dcf10d7ee534d54b8cf26a8f34c7d2ba446485ce273ce04e22c39a22e5346d55ea4f5 SHA512 7acf101f337af903318de263dcf78cf3b45b799bb6095bc79568fde7f3f56ca508d39a1d40ffe2a4ab0bdc0173f0ee2f4a7426f41e0855c1b7f9dfd86f7e6d73
diff --git a/dev-python/jupyter_server/jupyter_server-1.18.0.ebuild b/dev-python/jupyter_server/jupyter_server-1.18.0.ebuild
deleted file mode 100644
index 248b7cd68bc2..000000000000
--- a/dev-python/jupyter_server/jupyter_server-1.18.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=jupyter
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
- <dev-python/anyio-4[${PYTHON_USEDEP}]
- dev-python/argon2-cffi[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- >=dev-python/jupyter_client-6.1.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter_core-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.2.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/prometheus_client[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
- dev-python/send2trash[${PYTHON_USEDEP}]
- >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
- >=www-servers/tornado-6.1[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/pydata-sphinx-theme \
- dev-python/myst_parser \
- dev-python/ipython \
- dev-python/sphinxemoji \
- dev-python/sphinxcontrib-github-alt \
- dev-python/sphinxcontrib-openapi
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # This fails if your terminal is zsh (and maybe other non-bash as well?)
- tests/test_terminal.py::test_culling
- tests/test_terminal.py::test_terminal_create_with_cwd
- tests/test_terminal.py::test_terminal_create_with_relative_cwd
-)
-
-src_prepare() {
- # disable npm use
- sed -i -e '/\[tool\.jupyter-packaging\.builder\]/,+1d' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest \
- -p pytest_tornasync.plugin \
- -p jupyter_server.pytest_plugin \
- -p pytest_console_scripts \
- -p pytest_timeout
-}