summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-03 07:49:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-03 08:19:16 +0100
commite44bc729260681dd543624459ba82a6acb569e8f (patch)
tree1f47d81ee4e636dea13ac3840aa8fb5e1b1cc145 /dev-python/jupyter_server
parentdev-python/stripe: Bump to 5.1.0 (diff)
downloadgentoo-e44bc729260681dd543624459ba82a6acb569e8f.tar.gz
gentoo-e44bc729260681dd543624459ba82a6acb569e8f.tar.bz2
gentoo-e44bc729260681dd543624459ba82a6acb569e8f.zip
dev-python/jupyter_server: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_server')
-rw-r--r--dev-python/jupyter_server/Manifest1
-rw-r--r--dev-python/jupyter_server/jupyter_server-2.2.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/jupyter_server/Manifest b/dev-python/jupyter_server/Manifest
index e9a31ff5f233..0e1dcab0bbf1 100644
--- a/dev-python/jupyter_server/Manifest
+++ b/dev-python/jupyter_server/Manifest
@@ -2,3 +2,4 @@ DIST jupyter_server-1.19.1.tar.gz 453411 BLAKE2B 800231e7e7ddfcf2a2c2f2725971983
DIST jupyter_server-2.0.6.tar.gz 686312 BLAKE2B dfa309146e74c646ab28f31a4a7293d2b658771077240179aebd13176151c982035649acf3b78c86ddb06e914e3342e5894fb55f8b8711cb493a6a7c4b259cfa SHA512 186b41b13cc727d0674a49abcb9b3a9aa5b898f0e9e42124e46e862ec62528b4127b159a30352f33e6b91321f1dd3f086f82dca72d5616755bcf3220d154faa6
DIST jupyter_server-2.1.0.tar.gz 688227 BLAKE2B 8bc291d3c35a1eda61cb6eec4e19e42f8477252dddde194f10bfabd2035ca6c0e38a5e37a63ae8979eafa19ea0649c153db65686ec7fb91bc6c48dad8f7e61d4 SHA512 a33741425bc07250bf86e221f1fb330d65bb2984eb2db7bdd454670620f9d774a64f6a7b8ca5894e9ac1c175a3befc1ba2a516e30cde835c3ee29e7770505f6d
DIST jupyter_server-2.2.0.tar.gz 688879 BLAKE2B 07c5adee44bb4c7646c6f49b1108587773d2bdf78393a67a502fde198fc76e84b20385789ae0ab63863781e6f01babdf37462f6d62eeab87d32a9eeba457e03e SHA512 b236234515e066dfb4b68b9f510f123967fe57bfc396ecb2a46b6cc60c35e5b28a5b6eaafc70ae6133d49377e826d71994249b10665fd4c56fe7f248397cb777
+DIST jupyter_server-2.2.1.tar.gz 689208 BLAKE2B 27989736fd8cdc2dbfd48967c44966d3ef013f2def1e7aa7b8b76fdfdcbb4de9b22c7c910d6250413ee95e1279f4e0abaa460b8cbce58cabe43ca49ebc3c47f5 SHA512 6baa1fed933a7600e52c9e13ce6ae22556ebe6cb153218b174b1c26f5ff2662870d14bac18c719be358d68185863fadf00d672470f033b4883f18b98b56f842c
diff --git a/dev-python/jupyter_server/jupyter_server-2.2.1.ebuild b/dev-python/jupyter_server/jupyter_server-2.2.1.ebuild
new file mode 100644
index 000000000000..579b5167232a
--- /dev/null
+++ b/dev-python/jupyter_server/jupyter_server-2.2.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core services, APIs, and REST endpoints to Jupyter web applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_server/
+ https://pypi.org/project/jupyter-server/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/anyio-3.1.0[${PYTHON_USEDEP}]
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_events-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-6.4.4[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.6.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This fails if your terminal is zsh (and maybe other non-bash as well?)
+ tests/test_terminal.py
+ # Fails because above is ignored
+ tests/auth/test_authorizer.py
+ # Fails with additional extensions installed
+ tests/extension/test_app.py::test_stop_extension
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.1-skip-npm.patch"
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest \
+ -p pytest_tornasync.plugin \
+ -p jupyter_server.pytest_plugin \
+ -p pytest_console_scripts \
+ -p pytest_timeout
+}