summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-05 16:38:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-05 17:02:42 -0700
commit782e240b39dfb036a14e75078e50f568f7e223b1 (patch)
treed3909ea0de4145f7396e8688cb53166eda51da4e /dev-python/jwcrypto
parentnet-misc/connman: drop old (diff)
downloadgentoo-782e240b39dfb036a14e75078e50f568f7e223b1.tar.gz
gentoo-782e240b39dfb036a14e75078e50f568f7e223b1.tar.bz2
gentoo-782e240b39dfb036a14e75078e50f568f7e223b1.zip
dev-python/jwcrypto: bump
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-0.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index f58498d161f1..bcc2a5e6a8c4 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1 +1,2 @@
DIST jwcrypto-0.4.2.tar.gz 74332 BLAKE2B 4f779d00d58b7b17210042e7de943afcd766890e97859c487244899c10ee222326c68b74695b83034c09d00fbd43ad7108a5dcb84e019a8422722893198858e0 SHA512 38994a1274ce3a66d3a6a3e36f83b311b172e260129c94c70ae02e6d62b7a2fbcc07fd4353d3bf45f0c7f40c63322a3f489c8b1bda80c7511ae7a2136a2415dd
+DIST jwcrypto-0.7.0.tar.gz 80869 BLAKE2B 7b8a6928dff40d4d3e0bd61cfc81362ed5d0abd1001e1273aa12111166ed13e510d9cff935724578c2b7392bc74ffc94b0a733ea23f4a982e6bd8d35b1155ef4 SHA512 1d2b6268a54f3a3d466f7a7f7f0776164f0f35420b026c8ebfba099df530d965697eea85a49a73c44713e38fdb9ec4018cd4813b8e154a18117fc4006aa5578e
diff --git a/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild b/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild
new file mode 100644
index 000000000000..19f2c548671d
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+
+HOMEPAGE="https://github.com/latchset/jwcrypto"
+SRC_URI="https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/cryptography-1.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die
+}