summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-06-05 09:45:50 -0500
committerTony Vroon <chainsaw@gentoo.org>2018-07-23 17:01:02 +0100
commit2cff6b95aaa3657f0405fe0b836b013f5c96faa9 (patch)
treec3a98bc12d09a1199f54ed38932cfbe522e9608e /dev-python/kaitaistruct/kaitaistruct-0.8.ebuild
parentnet-misc/netkit-telnetd: revbump to new Debian patchlevel (diff)
downloadgentoo-2cff6b95aaa3657f0405fe0b836b013f5c96faa9.tar.gz
gentoo-2cff6b95aaa3657f0405fe0b836b013f5c96faa9.tar.bz2
gentoo-2cff6b95aaa3657f0405fe0b836b013f5c96faa9.zip
dev-python/kaitaistruct: Introducing new package
Introducing dev-python/kaitaistruct into Gentoo repository. Closes: https://bugs.gentoo.org/654860 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9251 Closes: https://bugs.gentoo.org/654860
Diffstat (limited to 'dev-python/kaitaistruct/kaitaistruct-0.8.ebuild')
-rw-r--r--dev-python/kaitaistruct/kaitaistruct-0.8.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/kaitaistruct/kaitaistruct-0.8.ebuild b/dev-python/kaitaistruct/kaitaistruct-0.8.ebuild
new file mode 100644
index 000000000000..bc1eb4526a51
--- /dev/null
+++ b/dev-python/kaitaistruct/kaitaistruct-0.8.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Kaitai Struct runtime for Python"
+HOMEPAGE="https://kaitai.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"