summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-26 22:09:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-26 22:09:39 -0500
commit79131e2047b172b51aa73f15e949abb5dc9a6480 (patch)
treea7bbb4fed57590675b205fed6cc3a75f940a409a /dev-python/keyring/keyring-12.2.0.ebuild
parentapp-admin/ansible: 2.5.2 bup (diff)
downloadgentoo-79131e2047b172b51aa73f15e949abb5dc9a6480.tar.gz
gentoo-79131e2047b172b51aa73f15e949abb5dc9a6480.tar.bz2
gentoo-79131e2047b172b51aa73f15e949abb5dc9a6480.zip
dev-python/keyring: 12.2.0 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-python/keyring/keyring-12.2.0.ebuild')
-rw-r--r--dev-python/keyring/keyring-12.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-12.2.0.ebuild b/dev-python/keyring/keyring-12.2.0.ebuild
new file mode 100644
index 000000000000..9b35a1c4afbe
--- /dev/null
+++ b/dev-python/keyring/keyring-12.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="mirror://pypi/k/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/collective-checkdocs[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+src_unpack() {
+ unpack $A
+ # This is an interactive test.
+ rm -f "${S}"/keyring/tests/backends/test_kwallet.py
+}
+
+python_test() {
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}