summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-07 09:01:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 10:26:29 +0100
commit7b9e47bef58a3caa33a905ee03a63572cbfe3c81 (patch)
tree317c801f0a673e96c966599b0cdeb4af74803bba /dev-python/keyring
parentpypi.eclass: Permit EAPI 7 (diff)
downloadgentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.tar.gz
gentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.tar.bz2
gentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.zip
dev-python/keyring: Switch to using PyPI sdist
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest2
-rw-r--r--dev-python/keyring/keyring-23.13.1-r1.ebuild15
2 files changed, 2 insertions, 15 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index a6c040323cd6..6bad012465c2 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1 @@
-DIST keyring-23.13.1.gh.tar.gz 49199 BLAKE2B 46ac7cb3237c7e0a061e9c4c30dba02d9a9c92d377f3db1b79b1c9bc4c5b8b866ffbda8354bbe5848a9db4c6834aec1c0b36f75d5c540ccc29ab71bd6adf30f4 SHA512 b0fc17157536178bba3a8f27f152a1cba497bc9ba2fc73d29ac9d8e61a2be51bdb0dea100eef9ab59979a9b0f8c8d15ca222e5fdc2c7d06d202955b18f21bf24
+DIST keyring-23.13.1.tar.gz 59582 BLAKE2B fb39490ba857f97b9b89856059664dfe21495ffe651bb48ad4e2284efe3f3c7551d34bfb4c39518c2b9b5e31e61b91693301271750f4ec837567d7652b11e9ef SHA512 7e56380e7311a31d8703b9e3beb74a8c8ce026f6cf9e1792780d349f3db61f50a1905c7d509a7013dd7cb47428dd3c28c3620815f01d3c4dbd7f648e056539d0
diff --git a/dev-python/keyring/keyring-23.13.1-r1.ebuild b/dev-python/keyring/keyring-23.13.1-r1.ebuild
index fcef2b34ff55..31b420a665bd 100644
--- a/dev-python/keyring/keyring-23.13.1-r1.ebuild
+++ b/dev-python/keyring/keyring-23.13.1-r1.ebuild
@@ -6,17 +6,13 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Provides access to the system keyring service"
HOMEPAGE="
https://github.com/jaraco/keyring/
https://pypi.org/project/keyring/
"
-SRC_URI="
- https://github.com/jaraco/keyring/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
SLOT="0"
LICENSE="PSF-2"
@@ -39,8 +35,6 @@ BDEPEND="
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
EPYTEST_DESELECT=(
# this test fails if importlib-metadata returns more than one
# entry, i.e. when keyring is installed already
@@ -53,10 +47,3 @@ EPYTEST_IGNORE=(
# hangs
tests/backends/test_kwallet.py
)
-
-python_compile() {
- distutils-r1_python_compile
- # https://github.com/jaraco/keyring/issues/621
- python_moduleinto keyring
- python_domodule keyring/{py.typed,*.zsh}
-}