summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-13 05:46:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-13 06:28:40 +0100
commit897a2c36fe6c61b9f049542ec53dba60307bfd6e (patch)
treea0a76324f3dfa7f726f805bcd7fed817921eb735 /dev-python/keyring
parentdev-python/zeroconf: Bump to 0.125.0 (diff)
downloadgentoo-897a2c36fe6c61b9f049542ec53dba60307bfd6e.tar.gz
gentoo-897a2c36fe6c61b9f049542ec53dba60307bfd6e.tar.bz2
gentoo-897a2c36fe6c61b9f049542ec53dba60307bfd6e.zip
dev-python/keyring: Bump to 24.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-24.3.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 54779e97fc08..96700d51cec1 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-24.2.0.tar.gz 59020 BLAKE2B 2377431b1f6af5eb76e3b243e3684c68c2c91d0e8cf28a8cd902cbb5e4291ca789afe813978e7171d766724c7238f5c0c68d995de2cfc6f99127a167bf3400da SHA512 f212d8df880e1060a62f6556335f8c8fcac1ff2f0390fdb8fff970eb90713e011fdb72796cfeb84d0c9eee9f2f2a21c4795e046c961d250226ec750ece2dcfa4
+DIST keyring-24.3.0.tar.gz 59666 BLAKE2B 6f68a6057f25c4e9841e04f2977da0401f09e15c6aeb04d12440de054049af9ece867befdd9fd26acab27cf0a00f3eeba9b7989c74eae88f96411f53cf86e594 SHA512 22467924420cc8646ebb10e2aa851e734c0a2ba9a7298987eba0849dbcba0abd295705f3b80fb6975c24e07ec029c0e406213275fa209fe2ca3e5b0c114e1612
diff --git a/dev-python/keyring/keyring-24.3.0.ebuild b/dev-python/keyring/keyring-24.3.0.ebuild
new file mode 100644
index 000000000000..880eb4ef91b7
--- /dev/null
+++ b/dev-python/keyring/keyring-24.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.4[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)