summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-14 09:35:08 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-15 16:31:07 -0700
commitdb051ff2c1b1a003e8881ccdfce2e5c5adcc0b59 (patch)
treec1825ef2a9125d2151a7ebe469af74b35c4eb0e8 /dev-python/keyring
parentprofiles: mask USE=test on gnome-base/gnome-settings-daemon (diff)
downloadgentoo-db051ff2c1b1a003e8881ccdfce2e5c5adcc0b59.tar.gz
gentoo-db051ff2c1b1a003e8881ccdfce2e5c5adcc0b59.tar.bz2
gentoo-db051ff2c1b1a003e8881ccdfce2e5c5adcc0b59.zip
dev-python/keyring: disable interactive test
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/keyring-10.4.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-10.4.0.ebuild b/dev-python/keyring/keyring-10.4.0.ebuild
index 2ed6a9125603..26a85f01a7ad 100644
--- a/dev-python/keyring/keyring-10.4.0.ebuild
+++ b/dev-python/keyring/keyring-10.4.0.ebuild
@@ -26,6 +26,12 @@ DEPEND="
)"
RDEPEND=""
+src_unpack() {
+ unpack $A
+ # This is an interactive test.
+ rm -f "${S}"/keyring/tests/backends/test_kwallet.py
+}
+
python_test() {
py.test -v -v || die "testsuite failed under ${EPYTHON}"
}